summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-07-05 08:08:24 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-07-05 08:08:24 +0200
commit78893e494fae29e990504d527800096efb48299e (patch)
tree1405fc378030bc9e3e3dbee592079358ff1c1c6e /sci-libs
parentdev-python/python-engineio: Bump to 4.3.3 (diff)
downloadgentoo-78893e494fae29e990504d527800096efb48299e.tar.gz
gentoo-78893e494fae29e990504d527800096efb48299e.tar.bz2
gentoo-78893e494fae29e990504d527800096efb48299e.zip
sci-libs/pytorch: add USE flags controlling caffe2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pytorch/metadata.xml11
-rw-r--r--sci-libs/pytorch/pytorch-1.11.0.ebuild2
2 files changed, 13 insertions, 0 deletions
diff --git a/sci-libs/pytorch/metadata.xml b/sci-libs/pytorch/metadata.xml
index d12749aa5c21..bc2785e5f6db 100644
--- a/sci-libs/pytorch/metadata.xml
+++ b/sci-libs/pytorch/metadata.xml
@@ -5,6 +5,17 @@
<email>tupone@gentoo.org</email>
<name>Tupone Alfredo</name>
</maintainer>
+ <use>
+ <flag name="cuda">Add support for CUDA processing</flag>
+ <flag name="ffmpeg">Add support for video processing operators</flag>
+ <flag name="nnpack">Use NNPACK</flag>
+ <flag name="numpy">Add support for math operations through numpy</flag>
+ <flag name="opencl">Use OpenCL</flag>
+ <flag name="opencv">Add support for image processing operators</flag>
+ <flag name="openmp">Use OpenMP for parallel code</flag>
+ <flag name="qnnpack">Use QNNPACK</flag>
+ <flag name="xnnpack">Use XNNPACK</flag>
+ </use>
<upstream>
<remote-id type="github">pytorch/pytorch</remote-id>
</upstream>
diff --git a/sci-libs/pytorch/pytorch-1.11.0.ebuild b/sci-libs/pytorch/pytorch-1.11.0.ebuild
index 0a1cae78f4bb..401bdea8264a 100644
--- a/sci-libs/pytorch/pytorch-1.11.0.ebuild
+++ b/sci-libs/pytorch/pytorch-1.11.0.ebuild
@@ -16,11 +16,13 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
RESTRICT="test"
+IUSE="cuda ffmpeg nnpack +numpy opencl opencv openmp qnnpack xnnpack"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="
${PYTHON_DEPS}
~sci-libs/caffe2-${PV}[${PYTHON_USEDEP}]
+ sci-libs/caffe2[cuda?,ffmpeg?,nnpack?,numpy?,opencl?,opencv?,openmp?,qnnpack?,xnnpack?]
dev-python/typing-extensions[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}