summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-03-18 18:16:18 +0000
committerSam James <sam@gentoo.org>2024-06-26 10:19:17 +0100
commit8571edbce169582908e77b574b7d2b7dcd0678a7 (patch)
treed74adc7c7d77a20c16bb6c2abc17850cc5dfe0e4 /sci-libs
parentsci-libs/rocWMMA: add 6.1.1 (diff)
downloadgentoo-8571edbce169582908e77b574b7d2b7dcd0678a7.tar.gz
gentoo-8571edbce169582908e77b574b7d2b7dcd0678a7.tar.bz2
gentoo-8571edbce169582908e77b574b7d2b7dcd0678a7.zip
sci-libs/hipBLAS: add 6.1.1
Changes: * Can be built with GCC; hipcc is not needed directly here * Rename ROCmSoftwarePlatform -> ROCm in URLs * Add myself as a maintainer Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hipBLAS/Manifest1
-rw-r--r--sci-libs/hipBLAS/hipBLAS-5.7.1.ebuild3
-rw-r--r--sci-libs/hipBLAS/hipBLAS-6.1.1.ebuild35
-rw-r--r--sci-libs/hipBLAS/metadata.xml6
4 files changed, 42 insertions, 3 deletions
diff --git a/sci-libs/hipBLAS/Manifest b/sci-libs/hipBLAS/Manifest
index 21eceaa7bab4..2e8dfa39138c 100644
--- a/sci-libs/hipBLAS/Manifest
+++ b/sci-libs/hipBLAS/Manifest
@@ -1,3 +1,4 @@
DIST hipBLAS-5.1.3.tar.gz 526704 BLAKE2B d32d7029ea910c341e00dccab1ee9ab984518368cf38524f2264bb808cc1242b3d57db283937650f54460cb01174ec90f02c4bd66866cba4be5d0a1855814f0e SHA512 41dbc86b7ea53e7c0f1d629130f90b719f864ceddae972f1c68911e97b6233286f0c22c0fcfce049ae7db73a1ed41bdaf730040c72f1790fca367362c14ac707
DIST hipBLAS-5.4.2.tar.gz 930814 BLAKE2B 702df09010b50652feb8f7e5741b27117aa58fc3e3b1b5f89f5043073a47581d1710f0831740453e84f7594b1b305e95d2681709898e5231c3eee2e8207404a3 SHA512 a941350d2d25022cf5142f68559242a048136bdd048dafcd544a0241cf3b510062273163f7a0eecc55f17ec47a1063d84d6102ca766ba7cde9b704eee5c44cd8
DIST hipBLAS-5.7.1.tar.gz 669163 BLAKE2B e065f77eba0bb99d347f71920e733d30b7693f9eaf0c1f2a87a169360ccff23b8294e367eebfd6489440308b9bb1ae662c39617c5bb94275bf9b0ed60d555f85 SHA512 24c074f07865e1a3dfb0aca0b1d494e340a584ecb408813bb5b053f8282437cfd3644d730163f4faf1b93da306626ba68904141f9c3730a29749537fb7fd1a63
+DIST hipBLAS-6.1.1.tar.gz 835570 BLAKE2B dc8a54f3b6c780f63e57f208d67b15e965d3a7c98e20766ef22ecfd41e8780a6b9464e31efad8003b52562222ec7ad06801d93a502ff99f8456f415db09e5ace SHA512 390b9a9bf0238a5c72d51d034c0053ec8c6b007547b1ec9561064828c24335e099ddb0402ad76e60018ec96742d5acfbb29b9d218a613e1c6d54e4b8b05ceca7
diff --git a/sci-libs/hipBLAS/hipBLAS-5.7.1.ebuild b/sci-libs/hipBLAS/hipBLAS-5.7.1.ebuild
index f5afa385cdee..f979363cda25 100644
--- a/sci-libs/hipBLAS/hipBLAS-5.7.1.ebuild
+++ b/sci-libs/hipBLAS/hipBLAS-5.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,7 +19,6 @@ RDEPEND="dev-util/hip
sci-libs/rocBLAS:${SLOT}[${ROCM_USEDEP}]
sci-libs/rocSOLVER:${SLOT}[${ROCM_USEDEP}]"
DEPEND="${RDEPEND}"
-BDEPEND=""
S="${WORKDIR}/hipBLAS-rocm-${PV}"
diff --git a/sci-libs/hipBLAS/hipBLAS-6.1.1.ebuild b/sci-libs/hipBLAS/hipBLAS-6.1.1.ebuild
new file mode 100644
index 000000000000..439a778540e9
--- /dev/null
+++ b/sci-libs/hipBLAS/hipBLAS-6.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+DESCRIPTION="ROCm BLAS marshalling library"
+HOMEPAGE="https://github.com/ROCm/hipBLAS"
+SRC_URI="https://github.com/ROCm/hipBLAS/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/hipBLAS-rocm-${PV}"
+
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocBLAS:${SLOT}[${ROCM_USEDEP}]
+ sci-libs/rocSOLVER:${SLOT}[${ROCM_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ # currently hipBLAS is a wrapper of rocBLAS which has tests, so no need to perform test here
+ -DBUILD_CLIENTS_TESTS=OFF
+ -DBUILD_CLIENTS_BENCHMARKS=OFF
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ cmake_src_configure
+}
diff --git a/sci-libs/hipBLAS/metadata.xml b/sci-libs/hipBLAS/metadata.xml
index 65b9259ded18..128eeacea7f9 100644
--- a/sci-libs/hipBLAS/metadata.xml
+++ b/sci-libs/hipBLAS/metadata.xml
@@ -12,7 +12,11 @@
<email>xgreenlandforwyy@gmail.com</email>
<name>Yiyang Wu</name>
</maintainer>
+ <maintainer type="person">
+ <email>lockalsash@gmail.com</email>
+ <name>Sv. Lockal</name>
+ </maintainer>
<upstream>
- <remote-id type="github">ROCmSoftwarePlatform/hipBLAS</remote-id>
+ <remote-id type="github">ROCm/hipBLAS</remote-id>
</upstream>
</pkgmetadata>