summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-12-22 23:26:06 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-12-22 23:26:53 +0100
commit9623a3e98fc0f8e3658488d31f0708505505fa89 (patch)
treeeef045dc58de057b1c3329d39def07b86a21340c /sci-libs
parentdev-python/flask-api: restrict to <dev-python/werkzeug-3 (diff)
downloadgentoo-9623a3e98fc0f8e3658488d31f0708505505fa89.tar.gz
gentoo-9623a3e98fc0f8e3658488d31f0708505505fa89.tar.bz2
gentoo-9623a3e98fc0f8e3658488d31f0708505505fa89.zip
sci-libs/caffe2: fix install without cuda
Closes: https://bugs.gentoo.org/920549 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/caffe2/caffe2-2.1.1-r4.ebuild (renamed from sci-libs/caffe2/caffe2-2.1.1-r3.ebuild)3
1 files changed, 3 insertions, 0 deletions
diff --git a/sci-libs/caffe2/caffe2-2.1.1-r3.ebuild b/sci-libs/caffe2/caffe2-2.1.1-r4.ebuild
index d2022d69585d..ac5b4024c28f 100644
--- a/sci-libs/caffe2/caffe2-2.1.1-r3.ebuild
+++ b/sci-libs/caffe2/caffe2-2.1.1-r4.ebuild
@@ -211,5 +211,8 @@ src_install() {
cp torch/version.py python/torch/ || die
python_domodule python/caffe2
python_domodule python/torch
+ if use cuda; then
+ python_domodule python/nvfuser
+ fi
find "${ED}" -empty -delete
}