summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2021-11-14 19:12:23 -0800
committerJason Zaman <perfinion@gentoo.org>2021-11-15 09:52:07 -0800
commita0c9a87f4f2da8408a7da7ed797c5b7817eddb43 (patch)
tree141ab220f4cb79a7a4823390d668a3c2ccfa898f /sci-libs
parentsci-visualization/tensorboard: Drop old 2.4.0 (diff)
downloadgentoo-a0c9a87f4f2da8408a7da7ed797c5b7817eddb43.tar.gz
gentoo-a0c9a87f4f2da8408a7da7ed797c5b7817eddb43.tar.bz2
gentoo-a0c9a87f4f2da8408a7da7ed797c5b7817eddb43.zip
sci-libs/tensorflow-estimator: Bump 2.7.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/tensorflow-estimator/Manifest1
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-2.7.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sci-libs/tensorflow-estimator/Manifest b/sci-libs/tensorflow-estimator/Manifest
index c6f60594dce9..2f6a618897da 100644
--- a/sci-libs/tensorflow-estimator/Manifest
+++ b/sci-libs/tensorflow-estimator/Manifest
@@ -5,3 +5,4 @@ DIST bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip 9422 BLA
DIST tensorflow-estimator-2.3.0.tar.gz 642118 BLAKE2B 29ecf5b64da20e8e6981375f1631b9b7e8ad061f71d0a3f1ac567bcd04b02102c5854d24e5106660f6bcd7b4ca683bd3bfbde51f236669d0f17e8f847feb7039 SHA512 0befc9c04650a0cd91ce90bc2e9a5d17ae3f7d8d8e4b8f763f223bbb891c73c7e2cbe91a2779af36342008e16f02d118120d94165c6a8e3c14a723b32ee29cb0
DIST tensorflow-estimator-2.4.0.tar.gz 660203 BLAKE2B b270536fe976fc718bb6ba558d9d91817b14951c8769365348d2cc13b621e30efe2154aa3040d2c0ea750d4f45b1aadd36d7f98b16bc2d3dcdec89f95ec6246b SHA512 31538614fb96c90228eebbc3edf7d7f7157dab1a9271858d47af2104d9fafab9f3386dc42a45ad46999df54fd757d544dd27fc23ee519596dd0a453a652bed13
DIST tensorflow-estimator-2.5.0.tar.gz 689339 BLAKE2B 6fb491b047cabed6edf67cccc913de54e4c2337eb052ba833239b72b07facaf33410b8a57a8f95fc0e2c225190d9b26b7955579d77883dbc236519cb784784c3 SHA512 dc49d92f4d2e63770dd901b272d7c62db50bfef7107e38f6525b6a458ad9915d1cbcdc9961c70c6ef88b9a38361f7b6712f6a2d30e240a35aab4bb25ffe17e71
+DIST tensorflow-estimator-2.7.0.tar.gz 691956 BLAKE2B 8a6cdc88fadbac6275d1c766c4b183dc7d1d374a1e898651ecdf0802d2f5c5bbc01d437a85826e3ef5dc0700b44c69ff84d8610fdf7ac3150fa4c0541f901707 SHA512 e02ee93baf2e36f2e42dec71bd2e31486dc96a7ff25d813fbbe3aae1d0eb1fccdda2cfcad46a87c6cdcd143c1b88915b95bc158ac3240a36734b725b3f89bda3
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-2.7.0.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.7.0.ebuild
new file mode 100644
index 000000000000..f6b9563e4cf6
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.7.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+MY_PN="estimator"
+MY_PV=${PV/_rc/-rc}
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+bazel_external_uris="
+ https://github.com/bazelbuild/rules_cc/archive/b1c40e1de81913a3c40e5948f78719c28152486d.zip -> bazelbuild-rules_cc-b1c40e1de81913a3c40e5948f78719c28152486d.zip
+ https://github.com/bazelbuild/rules_java/archive/7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip -> bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip"
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
+ ${bazel_external_uris}"
+
+RDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-java/java-config
+ >=dev-util/bazel-3.7.2"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ bazel_load_distfiles "${bazel_external_uris}"
+}
+
+src_prepare() {
+ bazel_setup_bazelrc
+ default
+ python_copy_sources
+}
+
+src_compile() {
+ export JAVA_HOME=$(java-config --jre-home)
+
+ do_compile() {
+ ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+ ebazel shutdown
+
+ local srcdir="${T}/src-${EPYTHON/./_}"
+ mkdir -p "${srcdir}" || die
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+ }
+
+ python_foreach_impl run_in_build_dir do_compile
+}
+
+src_install() {
+ do_install() {
+ cd "${T}/src-${EPYTHON/./_}" || die
+ esetup.py install
+ python_optimize
+ }
+ python_foreach_impl do_install
+
+ cd "${S}" || die
+ einstalldocs
+}