summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-04 15:23:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-04 15:39:40 +0200
commitba2beea8e2018c7383d0478a487acc34a28c9e1a (patch)
tree1460385154c238febed1bce1cd41748857031b9d /sci-mathematics/alt-ergo
parentx11-drivers/nvidia-drivers: migrate all remaining to linux-mod-r1 (diff)
downloadgentoo-ba2beea8e2018c7383d0478a487acc34a28c9e1a.tar.gz
gentoo-ba2beea8e2018c7383d0478a487acc34a28c9e1a.tar.bz2
gentoo-ba2beea8e2018c7383d0478a487acc34a28c9e1a.zip
sci-mathematics/alt-ergo: bump to 2.4.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/alt-ergo')
-rw-r--r--sci-mathematics/alt-ergo/Manifest1
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-2.4.3.ebuild76
-rw-r--r--sci-mathematics/alt-ergo/files/alt-ergo-2.4.3-dune.patch10
3 files changed, 87 insertions, 0 deletions
diff --git a/sci-mathematics/alt-ergo/Manifest b/sci-mathematics/alt-ergo/Manifest
index 49ac1bd63a83..7c1c762e20c7 100644
--- a/sci-mathematics/alt-ergo/Manifest
+++ b/sci-mathematics/alt-ergo/Manifest
@@ -1,2 +1,3 @@
DIST alt-ergo-2.4.1.tar.gz 2883046 BLAKE2B 6930080f7735f043e33d02b7fa0990c53992848796c0a5cf6ea4d7122eb6b9e5d6ac7ce420a4a19da35fa0ce5ff431bc228f2314a6f709f27a16bc7481bbacd5 SHA512 c3eee41d3c588ca89c2a1eebe9f10914ef647743b58fb562b682172cf6b6bdeb0920ebbba8a850820c0cb53bad0260f11b82fe71f00830ea9b33f5bb5d4fd048
DIST alt-ergo-2.4.2.tar.gz 2884553 BLAKE2B 95392625a6b17b3a2e41070a7f70ba124a95d99294f295d7c5a636a3327e6dac6b2153d1c90be4d24b72ce5ad22be5e174f6ae1c37663b093218a76ec1ada29a SHA512 61ae181ccd60a49f833ea79bbd5184a46f8eef24e7fe1169b15e905ed86584bdbe993ef86c203d5bfc3d79961024f96af0e4e623dc15479aa9538648291c9a75
+DIST alt-ergo-2.4.3.tar.gz 2902450 BLAKE2B bb8931dc512e3745496c1801fe959ac0fc4758b03049462506689021508a4ea364f0aae8679c776d8154c9f86a09080801c9b822d23355c572a24bd8b0e38210 SHA512 88a26b138e41997516085dbbf279e1ce11d03c18c0464ba80d5403dc80ff0f8cb5cbd4ad1489a60ff2a3b9539f9c55e4274008b14eed47b6fd057ce0a94ef98f
diff --git a/sci-mathematics/alt-ergo/alt-ergo-2.4.3.ebuild b/sci-mathematics/alt-ergo/alt-ergo-2.4.3.ebuild
new file mode 100644
index 000000000000..1ba42319bb6c
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-2.4.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="https://alt-ergo.ocamlpro.com
+ https://github.com/OCamlPro/alt-ergo/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OCamlPro/${PN}.git"
+else
+ SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="CeCILL-C"
+SLOT="0/${PV}"
+IUSE="examples gui +ocamlopt"
+REQUIRED_USE="ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.09.0:=[ocamlopt=]
+ >=sci-mathematics/psmt2-frontend-0.4.0:=
+
+ >=dev-ml/cmdliner-1.1.0:=
+ >=dev-ml/menhir-20181006:=
+ >=dev-ml/ocplib-simplex-0.4:=
+ dev-ml/camlzip:=
+ dev-ml/num:=
+ dev-ml/stdlib-shims:=
+ dev-ml/zarith:=
+ gui? (
+ dev-ml/lablgtk:3
+ dev-ml/lablgtk-sourceview:3
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/dune-build-info
+ dev-ml/dune-configurator
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.4.3-dune.patch )
+
+OCAML_SUBPACKAGES=(
+ alt-ergo-lib
+ alt-ergo-parsers
+ alt-ergo
+)
+
+src_prepare() {
+ default
+
+ if use gui ; then
+ OCAML_SUBPACKAGES+=( altgr-ergo )
+ fi
+}
+
+src_configure() {
+ sh ./configure --prefix /usr --libdir=/usr/$(get_libdir) || die
+}
+
+src_compile() {
+ dune-compile ${OCAML_SUBPACKAGES[@]}
+}
+
+src_install() {
+ dune-install ${OCAML_SUBPACKAGES[@]}
+
+ use examples && dodoc -r examples
+}
diff --git a/sci-mathematics/alt-ergo/files/alt-ergo-2.4.3-dune.patch b/sci-mathematics/alt-ergo/files/alt-ergo-2.4.3-dune.patch
new file mode 100644
index 000000000000..eea143fdd38a
--- /dev/null
+++ b/sci-mathematics/alt-ergo/files/alt-ergo-2.4.3-dune.patch
@@ -0,0 +1,10 @@
+--- a/src/lib/dune
++++ b/src/lib/dune
+@@ -21,7 +21,6 @@
+
+ ; external dependencies
+ (libraries
+- seq
+ unix
+ num
+ str