summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-10 19:56:18 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-10 20:16:34 +0100
commit0e78b666b7705cfa32d5ce5d560f734014cb3cb4 (patch)
treeae81bccbfd560dc5b8e4856e68527d218dfc269a /sci-mathematics
parentapp-emacs/buttercup: bump to 1.33 (diff)
downloadgentoo-0e78b666b7705cfa32d5ce5d560f734014cb3cb4.tar.gz
gentoo-0e78b666b7705cfa32d5ce5d560f734014cb3cb4.tar.bz2
gentoo-0e78b666b7705cfa32d5ce5d560f734014cb3cb4.zip
sci-mathematics/proverif: bump to 2.05
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/proverif/Manifest1
-rw-r--r--sci-mathematics/proverif/proverif-2.05.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sci-mathematics/proverif/Manifest b/sci-mathematics/proverif/Manifest
index 7c7ae0993907..1fff6166bc40 100644
--- a/sci-mathematics/proverif/Manifest
+++ b/sci-mathematics/proverif/Manifest
@@ -1 +1,2 @@
DIST proverif-v2.04.tar.bz2 61001112 BLAKE2B 03364d315bfa3d6cc8dfb68819be6b92301f554cf7ae4db0c4b9d8190a7d7576b79295dd536bf1356e12679028c100e6040d8c4e4299cf137c15114caf0216d2 SHA512 dbfafa62f4df72044b05563e10219b034ad49dd972598bf72eba616f2a88ff1cb85c3ee7bb9235050d0f35dbde750bffddbc93897b9ca2101dc6d153d3ea5575
+DIST proverif2.05.tar.gz 980879 BLAKE2B 738531d34249f1837a93c6897d7249e326213940cc9a8fc378a25912a4de4c122a6ce536a429f17c1ef7fae5dd5e1673cdf439d7bad2dd0f44826b33363dbc8a SHA512 e20d6dc40b0e4957590b9ce019ef654361f3514f53e0a5c3240a40d296ff2a50093630982b7a230c2277eadf4ed22ba1b6d09b48764c2ad3ec0e102033d1c486
diff --git a/sci-mathematics/proverif/proverif-2.05.ebuild b/sci-mathematics/proverif/proverif-2.05.ebuild
new file mode 100644
index 000000000000..16f222d7eaa0
--- /dev/null
+++ b/sci-mathematics/proverif/proverif-2.05.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo elisp-common findlib
+
+DESCRIPTION="Cryptographic protocol verifier in the formal model"
+HOMEPAGE="https://bblanche.gitlabpages.inria.fr/proverif/
+ https://gitlab.inria.fr/bblanche/proverif/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.inria.fr/bblanche/${PN}.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://bblanche.gitlabpages.inria.fr/proverif/${PN}${PV}.tar.gz"
+ S="${WORKDIR}/${PN}${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="emacs"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ emacs? ( >=app-editors/emacs-25:* )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( CHANGES README docs/dev docs/manual )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ edob sh ./build -nointeract
+
+ if use emacs ; then
+ cd "${S}/emacs" || die
+
+ elisp-compile *.el
+ fi
+}
+
+src_test() {
+ edob sh ./test
+}
+
+src_install() {
+ findlib_src_preinst
+
+ exeinto /usr/bin
+ doexe proverif
+ doexe proveriftotex
+
+ if use emacs ; then
+ elisp-install "${PN}" "${S}/emacs"/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ einstalldocs
+}