summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-12-16 08:59:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-12-16 08:59:14 +0000
commit8369d2f207056355b40aca5eb17375209c6ab606 (patch)
tree6d3e6832bbe73588b375b59dccff6073ccc76060 /sci-mathematics
parentdev-util/include-what-you-use: drop 0.23 (diff)
downloadgentoo-8369d2f207056355b40aca5eb17375209c6ab606.tar.gz
gentoo-8369d2f207056355b40aca5eb17375209c6ab606.tar.bz2
gentoo-8369d2f207056355b40aca5eb17375209c6ab606.zip
sci-mathematics/gmp-ecm: add 7.0.6
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gmp-ecm/Manifest1
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-7.0.6.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sci-mathematics/gmp-ecm/Manifest b/sci-mathematics/gmp-ecm/Manifest
index 9eed31676504..d1dc414b4ea0 100644
--- a/sci-mathematics/gmp-ecm/Manifest
+++ b/sci-mathematics/gmp-ecm/Manifest
@@ -1 +1,2 @@
DIST ecm-7.0.5.tar.gz 1159568 BLAKE2B 7fb8d78a6bc8423c9890b9d6e334f8c4317b68cde7d712c5306775c6f07eacb3cbbbd11d651bbbdd687a87692f4920170557b51f9498881a6c5018a2ce0b1b7f SHA512 f5a482a231339304683adc3334c9b86f21a0d9b42ea871418d4c01005057d560cd418eddfcc1c7be7f8c249960b2ee612a1454ccc5d8e41319b06c6f42e6662e
+DIST gmp-ecm-7.0.6.tar.bz2 609323 BLAKE2B 30255322bd8e8d49393044bcc55fd05905cb5b6b374c5f2ea59fa9b02864b22fc2b6f14fda2271a4148a2ec361fd524551cafd136bbbdf025137ce101c776def SHA512 7ad262e78c59d33218e1d783ffa79114c04fe4ddac57e4059577aecebbfe3af975c2e1ba6049452c1c96488660ed79fcb546237966489fc2edc03bf7710495c0
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.6.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.6.ebuild
new file mode 100644
index 000000000000..b8b236d35862
--- /dev/null
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs autotools
+
+MY_PN="ecm"
+MY_P="${MY_PN}-git-${PV}"
+DESCRIPTION="Elliptic Curve Method for Integer Factorization"
+HOMEPAGE="https://gitlab.inria.fr/zimmerma/ecm"
+SRC_URI="https://gitlab.inria.fr/zimmerma/ecm/-/archive/git-${PV}/${MY_PN}-git-${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv ~x86 ~ppc-macos ~x64-macos"
+IUSE="+custom-tune openmp cpu_flags_x86_sse2"
+
+DEPEND="dev-libs/gmp:="
+RDEPEND="${DEPEND}"
+
+# xsltproc is used to produce the manppage in combination with the
+# appropriate stylesheet
+BDEPEND="dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_compile() {
+ default
+ if use custom-tune; then
+ # One "emake" was needed to build the library. Now we can find
+ # the best set of parameters, and then run "emake" one more time
+ # to rebuild the library with the custom parameters. See the
+ # project's README or INSTALL-ecm. The build targets don't depend
+ # on ecm-params.h, so we need to "make clean" to force a rebuild.
+ emake ecm-params && emake clean && emake
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable openmp) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable custom-tune asm-redc)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}