summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-04-21 22:48:50 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-04-21 22:49:24 +0000
commit3b9c3631e5d828f18ba466878a6f9027c286a09a (patch)
tree37eb39c1cdb1fc906b85b48c4b5be0e448ebaa3e /sci-misc/fitsverify/fitsverify-4.18.ebuild
parentsys-apps/hwids: bump (diff)
downloadgentoo-3b9c3631e5d828f18ba466878a6f9027c286a09a.tar.gz
gentoo-3b9c3631e5d828f18ba466878a6f9027c286a09a.tar.bz2
gentoo-3b9c3631e5d828f18ba466878a6f9027c286a09a.zip
sci-misc/fitsverify: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-misc/fitsverify/fitsverify-4.18.ebuild')
-rw-r--r--sci-misc/fitsverify/fitsverify-4.18.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-misc/fitsverify/fitsverify-4.18.ebuild b/sci-misc/fitsverify/fitsverify-4.18.ebuild
new file mode 100644
index 000000000000..ccd81201e151
--- /dev/null
+++ b/sci-misc/fitsverify/fitsverify-4.18.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="FITS file format checker"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/fitsverify/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-libs/cfitsio:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ $(tc-getCC) ${CPPFLAGS} -DSTANDALONE ${CFLAGS} ${LDFLAGS} \
+ $($(tc-getPKG_CONFIG) --cflags cfitsio) \
+ ftverify.c fvrf*.c \
+ $($(tc-getPKG_CONFIG) --libs cfitsio) -o ${PN} \
+ || die "compiled failed"
+}
+
+src_install() {
+ dobin fitsverify
+ dodoc README
+}