summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-physics/sassena/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-physics/sassena/files')
-rw-r--r--sci-physics/sassena/files/sassena-1.4.1-libs.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-physics/sassena/files/sassena-1.4.1-libs.patch b/sci-physics/sassena/files/sassena-1.4.1-libs.patch
new file mode 100644
index 000000000000..cded9f7d40db
--- /dev/null
+++ b/sci-physics/sassena/files/sassena-1.4.1-libs.patch
@@ -0,0 +1,51 @@
+diff -urN sassena-v1.4.1/cmake/CMakeLists.txt.executables sassena-v1.4.1.patched/cmake/CMakeLists.txt.executables
+--- sassena-v1.4.1/cmake/CMakeLists.txt.executables 2012-02-03 04:43:33.000000000 +0400
++++ sassena-v1.4.1.patched/cmake/CMakeLists.txt.executables 2012-03-21 18:07:13.000000000 +0400
+@@ -61,6 +61,20 @@
+ INSTALL(TARGETS s_maketnx RUNTIME DESTINATION bin)
+ INSTALL(TARGETS s_stage RUNTIME DESTINATION bin)
+
++IF(NOT STATIC)
++INSTALL(TARGETS sass_controlio LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++INSTALL(TARGETS sass_decomposition LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++INSTALL(TARGETS sass_log LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++INSTALL(TARGETS sass_math LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++INSTALL(TARGETS sass_mpi LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++INSTALL(TARGETS sass_report LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++INSTALL(TARGETS sass_sample LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++INSTALL(TARGETS sass_scatter_devices LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++INSTALL(TARGETS sass_services LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++INSTALL(TARGETS sass_stager LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++INSTALL(TARGETS sass_vendor_xdrfile LIBRARY DESTINATION ${LIB_INSTALL_DIR})
++ENDIF(NOT STATIC)
++
+ TARGET_LINK_LIBRARIES (unit_broadcast
+ sass_log
+ sass_report
+@@ -69,4 +83,4 @@
+ ${BOOST_LIBRARIES}
+ )
+
+-INSTALL(TARGETS unit_broadcast RUNTIME DESTINATION bin)
+\ В конце файла нет новой строки
++INSTALL(TARGETS unit_broadcast RUNTIME DESTINATION bin)
+diff -urN sassena-v1.4.1/cmake/CMakeLists.txt.shared sassena-v1.4.1.patched/cmake/CMakeLists.txt.shared
+--- sassena-v1.4.1/cmake/CMakeLists.txt.shared 2012-02-03 04:43:33.000000000 +0400
++++ sassena-v1.4.1.patched/cmake/CMakeLists.txt.shared 2012-03-21 18:10:30.000000000 +0400
+@@ -4,6 +4,8 @@
+
+ SET(INTERNAL_LIBRARY_TYPE SHARED)
+
++SET(LIB_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib)
++
+ IF(CMAKE_HOST_APPLE)
+ SET(CMAKE_EXE_LINKER_FLAGS "-fPIC ${CMAKE_EXE_LINKER_FLAGS}")
+ ELSE(CMAKE_HOST_APPLE)
+@@ -15,4 +17,4 @@
+ INCLUDE(${CMAKE_PROJECT_PATH}/CMakeLists.txt.intern)
+ INCLUDE(${CMAKE_PROJECT_PATH}/CMakeLists.txt.executables)
+
+-INCLUDE(${CMAKE_PROJECT_PATH}/CMakeLists.txt.packages)
+\ В конце файла нет новой строки
++INCLUDE(${CMAKE_PROJECT_PATH}/CMakeLists.txt.packages)
+diff -urN sassena-v1.4.1/CMakeLists.txt sassena-v1.4.1.patched/CMakeLists.txt