summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-08 22:57:12 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-08 23:08:35 -0400
commitf149ed13e8e2abfc5cab650e1b417a2a6eb7a50f (patch)
tree46565c6ac69a7907ed2b955f4da411d6380b90da /sci-physics
parentapp-arch/gzip: embed canonical path to grep, not the one detected on $PATH (diff)
downloadgentoo-f149ed13e8e2abfc5cab650e1b417a2a6eb7a50f.tar.gz
gentoo-f149ed13e8e2abfc5cab650e1b417a2a6eb7a50f.tar.bz2
gentoo-f149ed13e8e2abfc5cab650e1b417a2a6eb7a50f.zip
sci-physics/pythia: mark as LTO-unsafe
It's very old code. So old, in fact, that upstream doesn't support it anymore and introduced a major new release series (which resulted in adding an outright SLOT to the ebuild) to port it to C++. And that was in 2012. The error itself is, naturally, fortran related. :) :) So there is simply no point in reporting this anywhere. The newer SLOT works fine. Simply prevent LTO. Anyways, no one is using 6.x except "to allow older published results to be reproduced, should the need arise". Free permission to not care about LTO... Closes: https://bugs.gentoo.org/927728 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/pythia/pythia-6.4.28-r2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/sci-physics/pythia/pythia-6.4.28-r2.ebuild b/sci-physics/pythia/pythia-6.4.28-r2.ebuild
index 01ffdc71dd71..14188ab9f6df 100644
--- a/sci-physics/pythia/pythia-6.4.28-r2.ebuild
+++ b/sci-physics/pythia/pythia-6.4.28-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools fortran-2
+inherit autotools flag-o-matic fortran-2
MV=$(ver_cut 1)
MY_PN=${PN}${MV}
@@ -70,6 +70,17 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/927728
+ #
+ # Fixed in SLOT 8, so no point in reporting it upstream or trying to fix
+ # it. The 6.x series is explicitly unsupported but graciously hosted "for
+ # reproduction of historic results".
+ #
+ # Anyway, the actual error is fortran related. The big feature of 8.x was
+ # porting to C++.
+ filter-lto
+
econf --disable-static
}