summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-04-10 16:10:53 -0700
committerJason Zaman <perfinion@gentoo.org>2022-04-10 20:43:46 -0700
commitd6040845a8c2ab9597da9dc670d74660ed340867 (patch)
tree41d2ecab533bde83366b2550e5565ec101e5c0bf /sys-apps/checkpolicy
parentsys-libs/libsemanage: update live ebuild (diff)
downloadgentoo-d6040845a8c2ab9597da9dc670d74660ed340867.tar.gz
gentoo-d6040845a8c2ab9597da9dc670d74660ed340867.tar.bz2
gentoo-d6040845a8c2ab9597da9dc670d74660ed340867.zip
sys-apps/checkpolicy: update live ebuild
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/checkpolicy')
-rw-r--r--sys-apps/checkpolicy/checkpolicy-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-apps/checkpolicy/checkpolicy-9999.ebuild b/sys-apps/checkpolicy/checkpolicy-9999.ebuild
index f2cee8075367..b699f09c01de 100644
--- a/sys-apps/checkpolicy/checkpolicy-9999.ebuild
+++ b/sys-apps/checkpolicy/checkpolicy-9999.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
inherit toolchain-funcs
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
DESCRIPTION="SELinux policy compiler"
HOMEPAGE="http://userspace.selinuxproject.org"
@@ -13,8 +16,9 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+ S="${WORKDIR}/${MY_P}"
fi
LICENSE="GPL-2"