summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-15 01:50:49 +0000
committerSam James <sam@gentoo.org>2023-03-15 01:51:05 +0000
commit0f03dcb7313744b9a7e7173c3bb19edba320459c (patch)
tree4263d2fcbad6a14e31871e454f79f1d2d3ce9099 /sys-apps/coreutils
parentsys-apps/ipmiutil: add 3.1.9 (diff)
downloadgentoo-0f03dcb7313744b9a7e7173c3bb19edba320459c.tar.gz
gentoo-0f03dcb7313744b9a7e7173c3bb19edba320459c.tar.bz2
gentoo-0f03dcb7313744b9a7e7173c3bb19edba320459c.zip
sys-apps/coreutils: sync w/ live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/coreutils-9.1_p20230313.ebuild2
-rw-r--r--sys-apps/coreutils/coreutils-9999.ebuild22
2 files changed, 14 insertions, 10 deletions
diff --git a/sys-apps/coreutils/coreutils-9.1_p20230313.ebuild b/sys-apps/coreutils/coreutils-9.1_p20230313.ebuild
index 2c0011780d87..1acd3418a030 100644
--- a/sys-apps/coreutils/coreutils-9.1_p20230313.ebuild
+++ b/sys-apps/coreutils/coreutils-9.1_p20230313.ebuild
@@ -66,7 +66,7 @@ BDEPEND="
dev-util/strace
${PYTHON_DEPS}
)
- verify-sig? ( >=sec-keys/openpgp-keys-coreutils-20230313 )
+ verify-sig? ( sec-keys/openpgp-keys-coreutils )
"
RDEPEND+="
hostname? ( !sys-apps/net-tools[hostname] )
diff --git a/sys-apps/coreutils/coreutils-9999.ebuild b/sys-apps/coreutils/coreutils-9999.ebuild
index 02afc582c965..1acd3418a030 100644
--- a/sys-apps/coreutils/coreutils-9999.ebuild
+++ b/sys-apps/coreutils/coreutils-9999.ebuild
@@ -21,7 +21,7 @@ if [[ ${PV} == 9999 ]] ; then
elif [[ ${PV} == *_p* ]] ; then
# Note: could put this in devspace, but if it's gone, we don't want
# it in tree anyway. It's just for testing.
- MY_SNAPSHOT="$(ver_cut 1-2).193-54bec"
+ MY_SNAPSHOT="$(ver_cut 1-2).198-e68b1"
SRC_URI="https://www.pixelbeat.org/cu/coreutils-${MY_SNAPSHOT}.tar.xz -> ${P}.tar.xz"
SRC_URI+=" verify-sig? ( https://www.pixelbeat.org/cu/coreutils-${MY_SNAPSHOT}.tar.xz.sig -> ${P}.tar.xz.sig )"
S="${WORKDIR}"/${PN}-${MY_SNAPSHOT}
@@ -41,14 +41,18 @@ SLOT="0"
IUSE="acl caps gmp hostname kill multicall nls +openssl selinux +split-usr static test vanilla xattr"
RESTRICT="!test? ( test )"
-LIB_DEPEND="acl? ( sys-apps/acl[static-libs] )
+LIB_DEPEND="
+ acl? ( sys-apps/acl[static-libs] )
caps? ( sys-libs/libcap )
gmp? ( dev-libs/gmp:=[static-libs] )
openssl? ( dev-libs/openssl:=[static-libs] )
- xattr? ( sys-apps/attr[static-libs] )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs]} )
+ xattr? ( sys-apps/attr[static-libs] )
+"
+RDEPEND="
+ !static? ( ${LIB_DEPEND//\[static-libs]} )
selinux? ( sys-libs/libselinux )
- nls? ( virtual/libintl )"
+ nls? ( virtual/libintl )
+"
DEPEND="
${RDEPEND}
static? ( ${LIB_DEPEND} )
@@ -96,8 +100,9 @@ src_unpack() {
elif use verify-sig ; then
# Needed for downloaded patch (which is unsigned, which is fine)
verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
- default
fi
+
+ default
}
src_prepare() {
@@ -211,9 +216,8 @@ src_test() {
addwrite /dev/full
#export RUN_EXPENSIVE_TESTS="yes"
#export FETISH_GROUPS="portage wheel"
- env PATH="${T}/mount-wrappers:${PATH}" emake -k check \
- gl_public_submodule_commit= \
- VERBOSE=yes
+ env PATH="${T}/mount-wrappers:${PATH}" gl_public_submodule_commit= \
+ emake -k check VERBOSE=yes
}
src_install() {