summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2018-02-24 19:31:48 +0000
committerPatrick Lauer <patrick@gentoo.org>2018-02-24 19:32:28 +0000
commitf8b890580ed2794c0e296a900d040f9c61c11538 (patch)
tree7f929ffe25c8929e94b991fb07d7d57ff804c622 /sys-apps/fakechroot/fakechroot-2.19.ebuild
parentx11-libs/gdk-pixbuf: stable 2.36.11 for ppc, bug #644770 (thanks to ernsteisw... (diff)
downloadgentoo-f8b890580ed2794c0e296a900d040f9c61c11538.tar.gz
gentoo-f8b890580ed2794c0e296a900d040f9c61c11538.tar.bz2
gentoo-f8b890580ed2794c0e296a900d040f9c61c11538.zip
sys-apps/fakechroot: Bump to 2.19 #639816
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps/fakechroot/fakechroot-2.19.ebuild')
-rw-r--r--sys-apps/fakechroot/fakechroot-2.19.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/fakechroot/fakechroot-2.19.ebuild b/sys-apps/fakechroot/fakechroot-2.19.ebuild
new file mode 100644
index 000000000000..4a89ac3de3c6
--- /dev/null
+++ b/sys-apps/fakechroot/fakechroot-2.19.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Provide a faked chroot environment without requiring root privileges"
+HOMEPAGE="http://fakechroot.alioth.debian.org/"
+SRC_URI="mirror://debian/pool/main/f/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS.md README.md
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}