summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-13 04:43:57 +0000
committerSam James <sam@gentoo.org>2023-02-13 04:43:57 +0000
commitf11fbdfbdc26af52fbd5f7f376fa3531f9feb839 (patch)
treee490be005697dddab9cdeea32bbb6ee1abe16ec8 /sys-apps/man-pages
parentsec-keys/openpgp-keys-lassecollin: add 20230213 (diff)
downloadgentoo-f11fbdfbdc26af52fbd5f7f376fa3531f9feb839.tar.gz
gentoo-f11fbdfbdc26af52fbd5f7f376fa3531f9feb839.tar.bz2
gentoo-f11fbdfbdc26af52fbd5f7f376fa3531f9feb839.zip
sys-apps/man-pages: add 6.03
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/man-pages')
-rw-r--r--sys-apps/man-pages/Manifest1
-rw-r--r--sys-apps/man-pages/man-pages-6.03.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/sys-apps/man-pages/Manifest b/sys-apps/man-pages/Manifest
index f8e0408de912..5e28005eff53 100644
--- a/sys-apps/man-pages/Manifest
+++ b/sys-apps/man-pages/Manifest
@@ -2,4 +2,5 @@ DIST man-pages-5.12.tar.xz 1778220 BLAKE2B 347c5ef63cb80134018f322f810545354ccc7
DIST man-pages-5.13.tar.xz 1788980 BLAKE2B 7cca88b7f201d177b087893f60e6a87fd3ed8c78a183bd6ebcd0c28961f5f5d24aa2ba9d3a1d9cec4e0fc9cc0b26489c91e991a2d4420c28e1f61b850b882752 SHA512 a68c0bd5f078aff2f13f962060863e5d30734c1c562e8e9e3d5eda5a329b18ad3e9b4ebb883d31cacfc0a476f91fccb8dd4257598acd75d09dd21351893d3499
DIST man-pages-6.01.tar.xz 1789204 BLAKE2B 37005b45af798315992fe4836457982d4203245eb546a6f1dcb02b67d63db1ba7e872b1259ebb58ee01178c726fff5f2276ec548ba768f73683edaee9a3233ca SHA512 93d09380a08c36740dbb2f3f246d190e5467147344b584253a2e0248fa764559008c21bb567f379f6166952ee1635ae3c2145e2a63aaf6d30728ca680d7b57a9
DIST man-pages-6.02.tar.xz 1800876 BLAKE2B 005bc57d2abca18516502faa7ea31798e6fb992d4a2fa1ce83dbba2992d9cc29e3b48fef97f1faa55bc40eafcb4eedbafb113dc2561f4a438f0a7fa711e259f0 SHA512 124e5157c25b5a3c62d225be1da2879f436d7fd8fe2f116c11982178e34085d1e50ef47e13fde413a7bf16d1177cbe744d00b2a178be3dfe4c4828371812ea5a
+DIST man-pages-6.03.tar.xz 2184824 BLAKE2B 16eba629c5fcbac7b52fa0ecf32d30d0e07308653d3617d1edf7503b6f983aa3f5145b1af7c5fcc96cb5a64ad425af7fe9be9a0da74c92c52d2d9b8fc60c9661 SHA512 df9de826c8289869fb27928f14eb28040b0f5bdae18247dc2ea847e660dd8bff9eee5656f6b2b38330abc64b69cad7cd44681bdf49173dd49a53877eaf725dba
DIST man-pages-gentoo-2.tar.bz2 5141 BLAKE2B c5c7956ab47c8a473e258b1902d5d19d9eb2e9d01786e907d9c3ba691c2a506834ed96cd1f54e8d8415e65d4fea0056659537f0faffe68fcbed33aa728a5e61e SHA512 6e6524b8ad6f1b8c9b147665ee32af49e05603dac61d433acd6b4f1164adef27cd542898f272b07d8659725013dac59c7f34a858968cc054a4785c945e14a770
diff --git a/sys-apps/man-pages/man-pages-6.03.ebuild b/sys-apps/man-pages/man-pages-6.03.ebuild
new file mode 100644
index 000000000000..36a5195a9ce7
--- /dev/null
+++ b/sys-apps/man-pages/man-pages-6.03.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Maintenance notes:
+# - Upstream are very friendly, do approach them if have any questions;
+#
+# - It's considered fine (and somewhat encouraged) for us to make snapshots
+# if we want specific fixes, perhaps aligned with newer kernels, glibc, etc.
+# Just generate it with 'make dist'. We can set DISTVERSION if we want a vanity
+# name or if the comit hash is too long;
+#
+# - If we do use a snapshot, *don't* grab it directly from git and use it
+# raw in the ebuild. Use 'make dist' as above;
+#
+# - Sometimes there's no dist tarball available post-release and upstream
+# encourage distros to make their own. Set MAN_PAGES_GENTOO_DIST to 1 if none is
+# available, 0 otherwise.
+MAN_PAGES_GENTOO_DIST=0
+GENTOO_PATCH=2
+
+DESCRIPTION="A somewhat comprehensive collection of Linux man pages"
+HOMEPAGE="https://www.kernel.org/doc/man-pages/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/docs/man-pages/man-pages.git"
+ inherit git-r3
+elif [[ ${PV} == *_rc* ]] ; then
+ MY_P=${PN}-${PV/_/-}
+
+ SRC_URI="https://git.kernel.org/pub/scm/docs/man-pages/man-pages.git/snapshot/${MY_P}.tar.gz"
+ S="${WORKDIR}"/${MY_P}
+else
+ if [[ ${MAN_PAGES_GENTOO_DIST} -eq 1 ]] ; then
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-gentoo.tar.xz"
+ else
+ SRC_URI="
+ https://www.kernel.org/pub/linux/docs/man-pages/Archive/${P}.tar.xz
+ https://www.kernel.org/pub/linux/docs/man-pages/${P}.tar.xz
+ "
+ fi
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SRC_URI+="
+ mirror://gentoo/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2
+ https://dev.gentoo.org/~cardoe/files/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2
+"
+
+LICENSE="man-pages GPL-2+ BSD"
+SLOT="0"
+# Keep the following in sync with app-i18n/man-pages-l10n
+MY_L10N=( cs da de el es fi fr hu id it mk nb nl pl pt-BR ro sr sv uk vi )
+IUSE="l10n_ja l10n_ru l10n_zh-CN ${MY_L10N[@]/#/l10n_}"
+RESTRICT="binchecks"
+
+BDEPEND="
+ sys-devel/bc
+"
+# Block packages that used to install colliding man pages:
+# bug #341953, bug #548900, bug #612640, bug #617462
+RDEPEND="
+ virtual/man
+ !<sys-apps/keyutils-1.5.9-r4
+ !<dev-libs/libbsd-0.8.3-r1
+"
+PDEPEND="
+ l10n_ja? ( app-i18n/man-pages-ja )
+ l10n_ru? ( || (
+ app-i18n/man-pages-l10n[l10n_ru(-)]
+ app-i18n/man-pages-ru
+ ) )
+ l10n_zh-CN? ( app-i18n/man-pages-zh_CN )
+"
+for lang in "${MY_L10N[@]}"; do
+ PDEPEND+=" l10n_${lang}? ( app-i18n/man-pages-l10n[l10n_${lang}(-)] )"
+done
+unset lang
+
+src_unpack() {
+ default
+
+ [[ ${PV} == 9999 ]] && git-r3_src_unpack
+}
+
+src_prepare() {
+ default
+
+ # passwd.5 installed by sys-apps/shadow, bug #776787
+ rm man5/passwd.5 || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake install prefix="${EPREFIX}"/usr DESTDIR="${D}"
+ dodoc README Changes*
+
+ # Override with Gentoo specific or additional Gentoo pages
+ cd "${WORKDIR}"/man-pages-gentoo || die
+ doman */*
+ dodoc README.Gentoo
+}
+
+pkg_postinst() {
+ for ver in ${REPLACING_VERSIONS} ; do
+ if ver_test ${ver} -lt 5.13-r2 ; then
+ # Avoid ACCEPT_LICENSE issues for users by default
+ # bug #871636
+ ewarn "This version of ${PN} no longer depends on sys-apps/man-pages-posix!"
+ ewarn "Please install sys-apps/man-pages-posix yourself if needed."
+ break
+ fi
+ done
+}