summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-01 02:29:54 +0000
committerSam James <sam@gentoo.org>2023-03-01 02:30:15 +0000
commit864252219e356b8e1b8184a2f60c3843cd14e95f (patch)
tree58cb855346ccca307804c66552b252d576051a35 /sys-apps/moar
parentsci-libs/gsl: fix configure w/ clang 16 (diff)
downloadgentoo-864252219e356b8e1b8184a2f60c3843cd14e95f.tar.gz
gentoo-864252219e356b8e1b8184a2f60c3843cd14e95f.tar.bz2
gentoo-864252219e356b8e1b8184a2f60c3843cd14e95f.zip
sys-apps/moar: add 1.12.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.12.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index d64f2f0d3445..70b13dff8acc 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -1,2 +1,4 @@
DIST moar-1.11.4-deps.tar.xz 25976728 BLAKE2B b1686e6608c8f27afa8704f7158a3d48482a580d8738389af78010a8d33c318152f6155b7c7be42058695653457eab75edb75905614c874f8a5ef15961b6689e SHA512 84b92f2b7d6b0cbc885e5486ca0d1051e3f3febe6a74e1e3afb11193c4b045dac28311d1f8f3a70eb996780c981f3f935174e2885c177c6a5f2c08c622b36fb5
DIST moar-1.11.4.tar.gz 2777910 BLAKE2B 7d192436c3c53200d8d29e7251d3f73b825b2a9364341d53d3b5a594d93c10bb5b1db4d9658adbce57d9fa111b140bd354c84211b776eb48fd2f27bda0f6dc77 SHA512 56fac97a8b897b4e9d086088153816b98b45897d4ddec173fbe25f8b3526207d7a3f8f7d5821dc1fc243acfad701c2920c6d4b68cdf513984bdcf5fbc4112268
+DIST moar-1.12.0-deps.tar.xz 26291664 BLAKE2B ebc16cbe23c26eacd84376b6e99d7484c753a065edd26d3d0ed7708595de61d6038f53f27c1bdc05032576eb11be3e2cbedbf9bdd2ecf8f8d467fd89eaf0a580 SHA512 dfd236a76bf4bb680b25a938e08bbd6874a554e9668f73af23d695c20403d1967f89fbeebfd54bb333bd86a7ca3e652a8418c6b9ada212aeb861cce4a70f0faf
+DIST moar-1.12.0.tar.gz 2777752 BLAKE2B fa2f442e2b0e6d909e77be8df873c7b08a82b43d881583a7f1c4a3591f2bbe90b5adc77524b92e0fcf071ce4a1c18d8c58c7cce18807974fae7342148d7fbe28 SHA512 bfa15f5fd3ffa4146adec9110fbf8fd3bc31c95877f5e24ab911d1ef9e357dd41b46e2f466f2ce7d2fc986e463dcf2e1132c0a42ebfe2c46a8cd216355c4b98b
diff --git a/sys-apps/moar/moar-1.12.0.ebuild b/sys-apps/moar/moar-1.12.0.ebuild
new file mode 100644
index 000000000000..766ab4317b72
--- /dev/null
+++ b/sys-apps/moar/moar-1.12.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI=" https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="!dev-lang/moarvm"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}