summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-04-21 21:05:32 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-04-21 21:05:36 +0100
commit16dea1437cb55c11a75b5b018e4ca18b501700d7 (patch)
treec89b18830b0a4ea43d329bfc617c1a2a8979bbce /sys-apps/zorroutils/zorroutils-0.05.ebuild
parentdev-python/easy-thumbnails: Retake for python@ (diff)
downloadgentoo-16dea1437cb55c11a75b5b018e4ca18b501700d7.tar.gz
gentoo-16dea1437cb55c11a75b5b018e4ca18b501700d7.tar.bz2
gentoo-16dea1437cb55c11a75b5b018e4ca18b501700d7.zip
sys-apps/zorroutils: bump up to 0.05
Reported-by: Michał Górny Closes: https://bugs.gentoo.org/696776 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-apps/zorroutils/zorroutils-0.05.ebuild')
-rw-r--r--sys-apps/zorroutils/zorroutils-0.05.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/zorroutils/zorroutils-0.05.ebuild b/sys-apps/zorroutils/zorroutils-0.05.ebuild
new file mode 100644
index 000000000000..f5e28bc3f6ca
--- /dev/null
+++ b/sys-apps/zorroutils/zorroutils-0.05.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Zorro bus utility for Amigas running 2.1 and later kernels"
+HOMEPAGE="http://users.telenet.be/geertu/Download/#zorro"
+SRC_URI="https://github.com/glaubitz/zorroutils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~m68k ~ppc"
+
+PATCHES=(
+ #"${FILESDIR}"/${PN}-0.04-20021014.diff
+ #"${FILESDIR}"/${PN}-gentoo.diff
+ "${FILESDIR}"/${PN}-0.05-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin lszorro
+ einstalldocs
+ doman *.8
+
+ insinto /usr/share/misc
+ doins zorro.ids
+}