summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-08-20 18:08:44 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-08-20 18:08:44 +0200
commit0614118c00cd8acb7be71765a21552c8cfc0e039 (patch)
tree1ba60f3269c49ccd218753e02e29d80b2ae79ffb /sys-apps
parentapp-admin/sudo: always install tmpfiles (diff)
downloadgentoo-0614118c00cd8acb7be71765a21552c8cfc0e039.tar.gz
gentoo-0614118c00cd8acb7be71765a21552c8cfc0e039.tar.bz2
gentoo-0614118c00cd8acb7be71765a21552c8cfc0e039.zip
sys-apps/xinetd: bump to v2.3.15.4
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xinetd/Manifest1
-rw-r--r--sys-apps/xinetd/xinetd-2.3.15.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-apps/xinetd/Manifest b/sys-apps/xinetd/Manifest
index 79afac57ab64..12b8ad8295b9 100644
--- a/sys-apps/xinetd/Manifest
+++ b/sys-apps/xinetd/Manifest
@@ -1,2 +1,3 @@
DIST xinetd-2.3.15.3.tar.xz 383204 BLAKE2B dada7e1efb8c70d9b47efbb33de54e643e195fc043a2fe8b1b61a1d9e597a5a10feda8d6692e665af1f1690870e619098a9a2367df3a73f7821a91777532f1fa SHA512 3a744d5ce66da46743eec28d5b95a44709b1828187078984e59d7220ac325abce1198927e9156f343a4e16a9dc63e8846f1dcb0facbf05ea44c73aecbe7e504f
+DIST xinetd-2.3.15.4.tar.xz 384504 BLAKE2B e6981d7143c5e39d45a6274d003467f372b1e97637112c66a3fd3a1cb47fe948228d72c914cca5b2db1d65a626b83ff36f10768d343579aa48353d20e2541f4d SHA512 1d9bbf5f60b299746adf3e57a669bf1a554b50066563b65cdb7584f00dcab2d3d331df705eefb56b51c52a16b5ed6b109cd832c27df87c7f262bb304e17ddc0e
DIST xinetd-2.3.15.tar.gz 309774 BLAKE2B b5c933a2aa7a2ef4a2d58b53890f04569fe592005c646f39a00d4716325c8ac9b9aa3b8b4b2f2b861430c8415167ab1d394de3d3b4bd761239c5223b1d2b0419 SHA512 9d6fee1fbc90329629d84086ae7de5cd51c25af7b68e52aa704d6f74bee5f0e3d54ca1bcf780f90f74ddc8d336ae0abb5e5e368d43c426a26b8dd2c4676d26aa
diff --git a/sys-apps/xinetd/xinetd-2.3.15.4.ebuild b/sys-apps/xinetd/xinetd-2.3.15.4.ebuild
new file mode 100644
index 000000000000..73781412652a
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.15.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic systemd toolchain-funcs autotools
+
+DESCRIPTION="powerful replacement for inetd"
+HOMEPAGE="https://github.com/xinetd-org/xinetd https://github.com/openSUSE/xinetd"
+SRC_URI="https://github.com/openSUSE/xinetd/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="perl rpc selinux tcpd"
+
+DEPEND="
+ rpc? ( net-libs/libtirpc:= )
+ selinux? ( sys-libs/libselinux )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
+"
+RDEPEND="
+ ${DEPEND}
+ perl? ( dev-lang/perl )
+"
+DEPEND="
+ ${DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ sed -i \
+ -e 's:/usr/bin/kill:/bin/kill:' \
+ "contrib/${PN}.service" || die
+}
+
+src_configure() {
+ econf \
+ $(use_with tcpd libwrap) \
+ $(use_with selinux labeled-networking) \
+ $(use_with rpc) \
+ --with-loadavg
+}
+
+src_install() {
+ default
+
+ use perl || rm -f "${ED}"/usr/sbin/xconv.pl
+
+ newinitd "${FILESDIR}"/xinetd.rc6 xinetd
+ newconfd "${FILESDIR}"/xinetd.confd xinetd
+ systemd_dounit "contrib/${PN}.service"
+
+ newdoc contrib/xinetd.conf xinetd.conf.dist.sample
+ dodoc README.md CHANGELOG
+}