summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-05 03:04:55 +0100
committerSam James <sam@gentoo.org>2024-08-05 03:04:55 +0100
commit1db0713fb5448663cb371e7c22281ad86a76dc49 (patch)
tree5346fc22641cfe0674ee42491429c7027e0b795a /sys-apps
parentmedia-libs/raptor: Stabilize 2.0.16 ppc64, #937305 (diff)
downloadgentoo-1db0713fb5448663cb371e7c22281ad86a76dc49.tar.gz
gentoo-1db0713fb5448663cb371e7c22281ad86a76dc49.tar.bz2
gentoo-1db0713fb5448663cb371e7c22281ad86a76dc49.zip
sys-apps/gentoo-functions: add 1.7
Bug: https://bugs.gentoo.org/937157 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gentoo-functions/Manifest1
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-1.7.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index e6428d450ab9..cbc96a0a7189 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -1,3 +1,4 @@
DIST gentoo-functions-0.19.tar.bz2 12079 BLAKE2B be0a3a54d4dee1755866047b670a69cd6fec368239123c3f0c08180b79a33c20147bca0e35e568faef6877513551e731bdf0c181aeb0460f6574d2d708219373 SHA512 2674d3fe5724cc6d685ae58bf0ee33f4a1bdba2c5e5809cfb193fd0a710d4678c2d9392c2c62d2321cf455f524950266dc1629ab684fe46632d179e539d5a39e
DIST gentoo-functions-1.5.tar.bz2 15808 BLAKE2B 99c330eb4c7f1d7af67b6f93dba565f9ea37c15e82d0b97157067279671dc3918668bf8120f7c410f018d67761cee41320efaec4df43639765d023b23a3a9a7f SHA512 f7add7770f40e110864f16978e968bfd937c1a5099e336cc04f6861483bae36ff7932f502994df1ddfa347beef8736bd39bd276bafbe04190c9915446457ce15
DIST gentoo-functions-1.6.tar.bz2 16795 BLAKE2B c901cdb8f2fcb507b5397e9ce674a12641f2129b9be05776bb272e09b9db3a6d205e6a00ef51f71b3203eac4e333b297cfe5ae5d61f9dd43074073a749ca171e SHA512 922b801c79f12d15bcabdb6cd52246cc60a4b512dfcc10bb3933f07d2ec03e01fe5be72502ae34c87374c8a7e880ce268e7dc8d1afcbd28b65efb51b9e467306
+DIST gentoo-functions-1.7.tar.bz2 25934 BLAKE2B f105d8dfab99d56256828ea833c1035445667d80261576a7c7ba3bc74cce64a58567a75d2dad37dff02836989bac2bd9d32f0fd87f93ca337f90eeb04889b991 SHA512 a7e8498dea93bf6f7796d25eb55fd440f9c675ef32d7c2e059bc8206adba7334b7f07b7510174e181dd88dbc9753494e3ff0fbd3c129a6f8524ee07a85edb8cf
diff --git a/sys-apps/gentoo-functions/gentoo-functions-1.7.ebuild b/sys-apps/gentoo-functions/gentoo-functions-1.7.ebuild
new file mode 100644
index 000000000000..8df3a1e88bad
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-1.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2014-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+inherit meson
+
+DESCRIPTION="Base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Specifically needs GNU find, as well.
+RDEPEND=">=sys-apps/findutils-4.9"
+
+src_configure() {
+ local emesonargs=(
+ # Deliberately avoid /usr as consumers assume we're at /lib/gentoo.
+ --prefix="${EPREFIX:-/}"
+ --mandir="${EPREFIX}/usr/share/man"
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}