summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-12-27 20:30:13 +0100
committerFabian Groffen <grobian@gentoo.org>2022-12-27 20:30:52 +0100
commiteedc8deda6d12b9e02f97c44dc16e95680e14c3e (patch)
tree24796f23badc3d5fd2fbd03149320510847202a2 /sys-apps
parentdev-util/pkgcheck: fix for pkgcore-0.12.18 (diff)
downloadgentoo-eedc8deda6d12b9e02f97c44dc16e95680e14c3e.tar.gz
gentoo-eedc8deda6d12b9e02f97c44dc16e95680e14c3e.tar.bz2
gentoo-eedc8deda6d12b9e02f97c44dc16e95680e14c3e.zip
sys-apps/file-5.44: add build patch for Solaris
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/file-5.44.ebuild1
-rw-r--r--sys-apps/file/files/file-5.44-limits-solaris.patch19
2 files changed, 20 insertions, 0 deletions
diff --git a/sys-apps/file/file-5.44.ebuild b/sys-apps/file/file-5.44.ebuild
index 41f62b904bd3..e300174f860d 100644
--- a/sys-apps/file/file-5.44.ebuild
+++ b/sys-apps/file/file-5.44.ebuild
@@ -54,6 +54,7 @@ BDEPEND+="
PATCHES=(
"${FILESDIR}/file-5.39-portage-sandbox.patch" #713710 #728978
"${FILESDIR}/file-5.40-seccomp-fstatat64-musl.patch" #789336, not upstream yet
+ "${FILESDIR}/file-5.44-limits-solaris.patch" # not upstream yet
)
src_prepare() {
diff --git a/sys-apps/file/files/file-5.44-limits-solaris.patch b/sys-apps/file/files/file-5.44-limits-solaris.patch
new file mode 100644
index 000000000000..7a04535577b4
--- /dev/null
+++ b/sys-apps/file/files/file-5.44-limits-solaris.patch
@@ -0,0 +1,19 @@
+softmagic: include limits.h for UINT_MAX usage
+
+Platforms like Solaris need this to compile.
+
+Bug: https://bugs.astron.com/view.php?id=413
+Signed-off-by: Fabian Groffen <grobian@gentoo.org>
+
+--- a/src/softmagic.c
++++ b/src/softmagic.c
+@@ -42,6 +42,7 @@
+ #include <ctype.h>
+ #include <stdlib.h>
+ #include <time.h>
++#include <limits.h>
+ #include "der.h"
+
+ file_private int match(struct magic_set *, struct magic *, file_regex_t **, size_t,
+
+