summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-03-31 20:24:48 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-03-31 22:48:07 +0300
commita23e4642a774a77a03630807498f26b76403321a (patch)
tree25da5d26ba9cf41192adb1f7ccc747f40bd71c18 /sys-block/bmap-tools/bmap-tools-3.6.ebuild
parentsys-apps/nvme-cli: add 2.4 (diff)
downloadgentoo-a23e4642a774a77a03630807498f26b76403321a.tar.gz
gentoo-a23e4642a774a77a03630807498f26b76403321a.tar.bz2
gentoo-a23e4642a774a77a03630807498f26b76403321a.zip
sys-block/bmap-tools: enable py3.11
Enable py3.11. Update EAPI 7 -> 8. Use PEP517 mode. Drop dev-python/nose, run tests with pytest. Add upstream patch to remove dev-python/mock. Closes: https://bugs.gentoo.org/833258 Closes: https://bugs.gentoo.org/836836 Closes: https://bugs.gentoo.org/878729 Closes: https://bugs.gentoo.org/897276 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-block/bmap-tools/bmap-tools-3.6.ebuild')
-rw-r--r--sys-block/bmap-tools/bmap-tools-3.6.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sys-block/bmap-tools/bmap-tools-3.6.ebuild b/sys-block/bmap-tools/bmap-tools-3.6.ebuild
deleted file mode 100644
index 5ba041f67df6..000000000000
--- a/sys-block/bmap-tools/bmap-tools-3.6.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Flashing tool using block maps and sparse files"
-HOMEPAGE="https://github.com/intel/bmap-tools"
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/intel/bmap-tools.git"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- SRC_URI="https://github.com/intel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="test"
-
-BDEPEND="${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}] )
-"
-
-RDEPEND="
- app-arch/pigz
- app-arch/lzop
- app-arch/lz4
- app-arch/pbzip2
- app-arch/xz-utils
- app-arch/bzip2
- app-arch/gzip
- app-arch/tar
-"
-
-DOCS=( "${S}/docs/README" )
-
-# tests are hanging using default below
-RESTRICT="!test? ( test )"
-
-distutils_enable_tests nose
-
-python_test() {
- # remaining tests involve way too much file I/O
- nosetests -sx --verbosity=3 --detailed-errors \
- tests/test_bmap_helpers.py \
- tests/test_compat.py || die "Tests fail with ${EPYTHON}"
-}