summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-09-20 13:44:03 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-09-20 13:44:03 +0300
commitbf9f50d371a21779894ab5e1eb77995938e6a646 (patch)
tree3187161c52d320a2c5a7cf84d6cd57bafc4717c4 /sys-block/buffer/buffer-1.19-r3.ebuild
parentnet-misc/pps-tools: Drop old (diff)
downloadgentoo-bf9f50d371a21779894ab5e1eb77995938e6a646.tar.gz
gentoo-bf9f50d371a21779894ab5e1eb77995938e6a646.tar.bz2
gentoo-bf9f50d371a21779894ab5e1eb77995938e6a646.zip
sys-block/buffer: port to EAPI=7
Closes: https://bugs.gentoo.org/742110 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-block/buffer/buffer-1.19-r3.ebuild')
-rw-r--r--sys-block/buffer/buffer-1.19-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-block/buffer/buffer-1.19-r3.ebuild b/sys-block/buffer/buffer-1.19-r3.ebuild
new file mode 100644
index 000000000000..8096ee92f513
--- /dev/null
+++ b/sys-block/buffer/buffer-1.19-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A tapedrive tool for speeding up reading from and writing to tape"
+HOMEPAGE="http://www.microwerks.net/~hugo/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc sparc x86"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PV}-deb-gentoo.patch
+ sed -i -e 's/$(CFLAGS)/\0 $(LDFLAGS)/' Makefile || die
+ emake clean
+ default
+}
+
+src_compile() {
+ append-lfs-flags
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin buffer
+ dodoc README
+ newman buffer.man buffer.1
+}