summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancisco Javier FĂ©lix <web@inode64.com>2022-11-18 10:00:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-11-18 10:17:54 +0200
commit74904d073233386155e4bf331823c33686f6225c (patch)
tree972b254a0fdb913e6bd771eb9465172c88a4c367 /sys-block/storcli/storcli-7.2405.ebuild
parentwww-apps/hugo: drop 0.101.0-r1 (diff)
downloadgentoo-74904d073233386155e4bf331823c33686f6225c.tar.gz
gentoo-74904d073233386155e4bf331823c33686f6225c.tar.bz2
gentoo-74904d073233386155e4bf331823c33686f6225c.zip
sys-block/storcli: add 7.2405
Closes: https://github.com/gentoo/gentoo/pull/28002 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-block/storcli/storcli-7.2405.ebuild')
-rw-r--r--sys-block/storcli/storcli-7.2405.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-block/storcli/storcli-7.2405.ebuild b/sys-block/storcli/storcli-7.2405.ebuild
new file mode 100644
index 000000000000..9ba4c0bb1174
--- /dev/null
+++ b/sys-block/storcli/storcli-7.2405.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm
+
+# Upstream is still using strange version numbers
+MY_PV="00${PV}.0000.0000"
+MY_P="${PN}-${MY_PV}"
+MY_PN="STORCLI_SAS3.5_P25"
+DESCRIPTION="MegaRAID StorCLI (successor of the MegaCLI)"
+HOMEPAGE="https://www.broadcom.com/support/download-search?dk=storcli"
+SRC_URI="https://docs.broadcom.com/docs-and-downloads/host-bus-adapters/host-bus-adapters-common-files/sas_sata_nvme_12g_p25/${MY_PN}.zip -> ${P}.zip"
+
+LICENSE="Avago LSI BSD"
+SLOT="0"
+KEYWORDS="-* amd64"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/opt/MegaRAID/storcli/storcli64"
+
+src_unpack() {
+ default
+ rpm_unpack ./${MY_PN}/univ_viva_cli_rel/Unified_storcli_all_os/Linux/${MY_P}-1.noarch.rpm
+ unzip ./${MY_PN}/univ_viva_cli_rel/Unified_storcli_all_os/JSON-Schema/JSON_SCHEMA_FILES.zip
+}
+
+src_prepare() {
+ default
+
+ sed -i -e 's|/home/|/usr/share/storcli/|g' JSON-Schema/*.json
+}
+
+src_install() {
+ insinto /usr/share/storcli
+ doins JSON-Schema/*.xlsx
+ doins ${MY_PN}/univ_viva_cli_rel/Unified_storcli_all_os/storcliconf.ini
+
+ insinto /usr/share/storcli/JSON-Schema/
+ doins JSON-Schema/*.json
+
+ exeinto /opt/MegaRAID/storcli
+ doexe opt/MegaRAID/storcli/storcli64
+
+ dosym ../../opt/MegaRAID/storcli/storcli64 /usr/sbin/storcli
+ dosym ../../opt/MegaRAID/storcli/storcli64 /usr/sbin/storcli64
+}