summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-03-17 19:28:03 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-18 21:00:12 +0100
commit4aa08381c1578f1e2d47890fd527d33df481a4ec (patch)
tree6dcdf8d7cf045fb90a354e0e5f6cb33bb74474ed /sys-boot
parentnet-dialup/wvdial: EAPI8 bump (diff)
downloadgentoo-4aa08381c1578f1e2d47890fd527d33df481a4ec.tar.gz
gentoo-4aa08381c1578f1e2d47890fd527d33df481a4ec.tar.bz2
gentoo-4aa08381c1578f1e2d47890fd527d33df481a4ec.zip
sys-boot/cromwell-bin: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/35803 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/cromwell-bin/cromwell-bin-2.40-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-boot/cromwell-bin/cromwell-bin-2.40-r2.ebuild b/sys-boot/cromwell-bin/cromwell-bin-2.40-r2.ebuild
new file mode 100644
index 000000000000..62059734f721
--- /dev/null
+++ b/sys-boot/cromwell-bin/cromwell-bin-2.40-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mount-boot
+
+DESCRIPTION="Xbox boot loader precompiled binaries from xbox-linux.org"
+HOMEPAGE="https://sourceforge.net/projects/xbox-linux/"
+SRC_URI="mirror://sourceforge/xbox-linux/cromwell-${PV}.tar.gz"
+S="${WORKDIR}/cromwell-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+RESTRICT="${RESTRICT} strip"
+
+src_install() {
+ insinto /boot/${PN}
+ doins cromwell{,_1024}.bin xromwell.xbe
+}