summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-01 20:01:09 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 20:02:14 +0100
commit4b85148a7c1196c409abe15da9c964f8d2aadc3b (patch)
treece2a6978da14a79eb3bfb303eb67d65066916ef1 /sys-cluster/ceph
parentsys-apps/i2c-tools: Fix Python dependencies (diff)
downloadgentoo-4b85148a7c1196c409abe15da9c964f8d2aadc3b.tar.gz
gentoo-4b85148a7c1196c409abe15da9c964f8d2aadc3b.tar.bz2
gentoo-4b85148a7c1196c409abe15da9c964f8d2aadc3b.zip
sys-cluster/ceph: Fix Python dependencies
DISTUTILS_USE_SETUPTOOLS is not used with DISTUTILS_OPTIONAL, the dep on setuptools needs to be declared explicitly. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ceph-14.2.22-r1.ebuild6
-rw-r--r--sys-cluster/ceph/ceph-15.2.15-r2.ebuild6
-rw-r--r--sys-cluster/ceph/ceph-16.2.5.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/sys-cluster/ceph/ceph-14.2.22-r1.ebuild b/sys-cluster/ceph/ceph-14.2.22-r1.ebuild
index 9675c7235f2b..860ccfb14768 100644
--- a/sys-cluster/ceph/ceph-14.2.22-r1.ebuild
+++ b/sys-cluster/ceph/ceph-14.2.22-r1.ebuild
@@ -3,7 +3,6 @@
EAPI=7
PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
CMAKE_MAKEFILE_GENERATOR=emake
DISTUTILS_OPTIONAL=1
@@ -87,14 +86,15 @@ DEPEND="
system-boost? ( dev-libs/boost:=[threads(+),context,python,${PYTHON_USEDEP}] )
xfs? ( sys-fs/xfsprogs:= )
zfs? ( sys-fs/zfs:= )
- ${PYTHON_DEPS}
"
BDEPEND="
+ ${PYTHON_DEPS}
amd64? ( dev-lang/yasm )
x86? ( dev-lang/yasm )
app-arch/cpio
>=dev-util/cmake-3.5.0
dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx
dev-util/cunit
dev-util/gperf
@@ -116,6 +116,7 @@ BDEPEND="
)
"
RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
app-admin/sudo
net-misc/socat
sys-apps/gptfdisk
@@ -133,6 +134,7 @@ RDEPEND="${DEPEND}
dev-python/prettytable[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]
mgr? (
dev-python/more-itertools[${PYTHON_USEDEP}]
diff --git a/sys-cluster/ceph/ceph-15.2.15-r2.ebuild b/sys-cluster/ceph/ceph-15.2.15-r2.ebuild
index 8d09a94fc96e..6faac62ff814 100644
--- a/sys-cluster/ceph/ceph-15.2.15-r2.ebuild
+++ b/sys-cluster/ceph/ceph-15.2.15-r2.ebuild
@@ -3,7 +3,6 @@
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
CMAKE_MAKEFILE_GENERATOR=emake
DISTUTILS_OPTIONAL=1
@@ -95,14 +94,15 @@ DEPEND="
uring? ( sys-libs/liburing:= )
xfs? ( sys-fs/xfsprogs:= )
zfs? ( sys-fs/zfs:= )
- ${PYTHON_DEPS}
"
BDEPEND="
+ ${PYTHON_DEPS}
amd64? ( dev-lang/yasm )
x86? ( dev-lang/yasm )
app-arch/cpio
>=dev-util/cmake-3.5.0
dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx
dev-util/cunit
dev-util/gperf
@@ -124,6 +124,7 @@ BDEPEND="
)
"
RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
app-admin/sudo
net-misc/socat
sys-apps/gptfdisk
@@ -143,6 +144,7 @@ RDEPEND="${DEPEND}
dev-python/prettytable[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]
mgr? (
dev-python/jsonpatch[${PYTHON_USEDEP}]
diff --git a/sys-cluster/ceph/ceph-16.2.5.ebuild b/sys-cluster/ceph/ceph-16.2.5.ebuild
index 37d70a69897e..4e1446212d24 100644
--- a/sys-cluster/ceph/ceph-16.2.5.ebuild
+++ b/sys-cluster/ceph/ceph-16.2.5.ebuild
@@ -4,7 +4,6 @@
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
DISTUTILS_OPTIONAL=1
LUA_COMPAT=( lua5-3 )
@@ -102,14 +101,15 @@ DEPEND="
xfs? ( sys-fs/xfsprogs:= )
zbd? ( sys-block/libzbd:= )
zfs? ( sys-fs/zfs:= )
- ${PYTHON_DEPS}
"
BDEPEND="
+ ${PYTHON_DEPS}
amd64? ( dev-lang/nasm )
x86? ( dev-lang/yasm )
app-arch/cpio
>=dev-util/cmake-3.5.0
dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx
dev-util/cunit
dev-util/gperf
@@ -136,6 +136,7 @@ BDEPEND="
"
RDEPEND="
${DEPEND}
+ ${PYTHON_DEPS}
app-admin/sudo
net-misc/socat
sys-apps/gptfdisk
@@ -155,6 +156,7 @@ RDEPEND="
dev-python/prettytable[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]
mgr? (
dev-python/jsonpatch[${PYTHON_USEDEP}]