summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2022-07-11 22:34:58 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-07-23 15:50:17 +0300
commit4be63a6fbf68a239d28e28bddce2f81b57d470c1 (patch)
tree5d177d29ff51ea3b622dff4e6b7b18fe9fe0c5b7 /sys-cluster/glusterfs
parentapp-editors/scite: Add Fix from bug #765151 (diff)
downloadgentoo-4be63a6fbf68a239d28e28bddce2f81b57d470c1.tar.gz
gentoo-4be63a6fbf68a239d28e28bddce2f81b57d470c1.tar.bz2
gentoo-4be63a6fbf68a239d28e28bddce2f81b57d470c1.zip
sys-cluster/glusterfs: revbump to fix init.d file
Fix initd $(( ... )) vs (( ... )). The former returns the result, then attempts to execute it, the latter merely executes the math. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/26354 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/glusterfs')
-rw-r--r--sys-cluster/glusterfs/files/glusterd-10.2-r1.initd (renamed from sys-cluster/glusterfs/files/glusterd-10.2.initd)2
-rw-r--r--sys-cluster/glusterfs/glusterfs-10.2-r1.ebuild (renamed from sys-cluster/glusterfs/glusterfs-10.2.ebuild)2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-cluster/glusterfs/files/glusterd-10.2.initd b/sys-cluster/glusterfs/files/glusterd-10.2-r1.initd
index af8f941d87d7..f5210ef7cd1c 100644
--- a/sys-cluster/glusterfs/files/glusterd-10.2.initd
+++ b/sys-cluster/glusterfs/files/glusterd-10.2-r1.initd
@@ -23,7 +23,7 @@ start_post() {
local c=0
ebegin "Waiting for glusterd to start up"
while ! /usr/sbin/gluster volume list >/dev/null 2>&1 && [ "${c}" -lt "${glusterd_max_wait_start-60}" ]; do
- $(( c=c+1 ))
+ (( c=c+1 ))
done
[ "${c}" -lt "${glusterd_max_wait_start-60}" ]
eend $?
diff --git a/sys-cluster/glusterfs/glusterfs-10.2.ebuild b/sys-cluster/glusterfs/glusterfs-10.2-r1.ebuild
index 2551faf99a31..9f76a974689c 100644
--- a/sys-cluster/glusterfs/glusterfs-10.2.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-10.2-r1.ebuild
@@ -150,7 +150,7 @@ src_install() {
chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
newinitd "${FILESDIR}/glusterfsd-10.2.initd" glusterfsd
- newinitd "${FILESDIR}/glusterd-10.2.initd" glusterd
+ newinitd "${FILESDIR}/glusterd-10.2-r1.initd" glusterd
newconfd "${FILESDIR}/${PN}.confd" glusterfsd
keepdir /var/log/${PN}