summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-13 20:23:51 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-13 20:23:51 -0600
commitf741ca90126b001763694738673d8a14a1bde594 (patch)
tree40eaf70cdbcc6db777aa3ea4a95ae4bdfc7af1e1 /sys-cluster/heat/heat-2017.2.9999.ebuild
parentdev-libs/zlog: Revbump to 1.2.12-r1, handle libdir properly #628732 (diff)
downloadgentoo-f741ca90126b001763694738673d8a14a1bde594.tar.gz
gentoo-f741ca90126b001763694738673d8a14a1bde594.tar.bz2
gentoo-f741ca90126b001763694738673d8a14a1bde594.zip
sys-cluster/heat: 9.0.3 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-cluster/heat/heat-2017.2.9999.ebuild')
-rw-r--r--sys-cluster/heat/heat-2017.2.9999.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/sys-cluster/heat/heat-2017.2.9999.ebuild b/sys-cluster/heat/heat-2017.2.9999.ebuild
index 08a656c38a7a..472f8a0a47db 100644
--- a/sys-cluster/heat/heat-2017.2.9999.ebuild
+++ b/sys-cluster/heat/heat-2017.2.9999.ebuild
@@ -4,17 +4,24 @@
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} )
-inherit distutils-r1 eutils git-r3 linux-info user
+inherit distutils-r1 eutils linux-info user
DESCRIPTION="A CloudFormation-compatible openstack-native cloud orchestration engine."
HOMEPAGE="https://launchpad.net/heat"
-SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/heat/heat.conf.sample.pike -> heat.conf.sample-${PV}"
-EGIT_REPO_URI="https://github.com/openstack/heat.git"
-EGIT_BRANCH="stable/pike"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/heat/heat.conf.sample.pike -> heat.conf.sample-${PV}"
+ EGIT_REPO_URI="https://github.com/openstack/heat.git"
+ EGIT_BRANCH="stable/pike"
+else
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/heat/heat.conf.sample.pike -> heat.conf.sample-${PV}
+ https://tarballs.openstack.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
IUSE="+mysql +memcached postgres sqlite"
REQUIRED_USE="|| ( mysql postgres sqlite )"
@@ -81,8 +88,7 @@ RDEPEND="
>=dev-python/python-monascaclient-1.7.0[${PYTHON_USEDEP}]
>=dev-python/python-neutronclient-6.3.0[${PYTHON_USEDEP}]
>=dev-python/python-novaclient-9.0.0[${PYTHON_USEDEP}]
- >=dev-python/python-openstackclient-3.3.0[${PYTHON_USEDEP}]
- !~dev-python/python-openstackclient-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.11.0[${PYTHON_USEDEP}]
>=dev-python/python-saharaclient-1.1.0[${PYTHON_USEDEP}]
>=dev-python/python-senlinclient-1.1.0[${PYTHON_USEDEP}]
>=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]