summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-09-18 22:03:23 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-31 11:47:39 +0200
commit0bad8c8832e5840a2e10f55c7511af5e18ee0cb6 (patch)
tree35585941230cdebdfc3061b4771893264fe985b6 /sys-cluster/hpx
parentsys-cluster/hpx: Bump version to v1.5.1 (diff)
downloadgentoo-0bad8c8832e5840a2e10f55c7511af5e18ee0cb6.tar.gz
gentoo-0bad8c8832e5840a2e10f55c7511af5e18ee0cb6.tar.bz2
gentoo-0bad8c8832e5840a2e10f55c7511af5e18ee0cb6.zip
sys-cluster/hpx: Sync live ebuild
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index 168825c65b05..f8bb574e3255 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -3,16 +3,16 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_COMPAT=( python3_{6..9} )
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
else
- SRC_URI="https://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
+ SRC_URI="https://github.com/STEllAR-GROUP/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
-inherit cmake fortran-2 python-single-r1 check-reqs multiprocessing
+inherit check-reqs cmake multiprocessing python-single-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
@@ -35,7 +35,7 @@ BDEPEND="
$(python_gen_cond_dep '
dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
dev-python/sphinx_rtd_theme[${PYTHON_MULTI_USEDEP}]
- >=dev-python/breathe-4.14[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/breathe-4.22[${PYTHON_MULTI_USEDEP}]
')
)
test? ( ${PYTHON_DEPS} )