summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 16:09:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 16:53:25 +0200
commit23f4cb70632b56d1de43532d6b03617c10c486c1 (patch)
tree6c52ff0e1fa710339850aa73765a2e26b80be814 /sys-cluster/hpx
parentRevert "dev-lang/elixir: drop old" (diff)
downloadgentoo-23f4cb70632b56d1de43532d6b03617c10c486c1.tar.gz
gentoo-23f4cb70632b56d1de43532d6b03617c10c486c1.tar.bz2
gentoo-23f4cb70632b56d1de43532d6b03617c10c486c1.zip
sys-cluster/hpx: 1.2.1 version bump
Closes: https://bugs.gentoo.org/683470 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/Manifest1
-rw-r--r--sys-cluster/hpx/hpx-1.2.1.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
index dc91312422fc..d5182d17326c 100644
--- a/sys-cluster/hpx/Manifest
+++ b/sys-cluster/hpx/Manifest
@@ -2,3 +2,4 @@ DIST hpx_0.9.99.tar.gz 3779841 BLAKE2B fae6b06a303964e3d52d68fcfd980f89625bfd2a7
DIST hpx_1.0.0.tar.gz 3972403 BLAKE2B 737282f2b547c2ce7e6e0367df64beaf22760d73840f2f1b983e8b970baef074b376f264a97f8c67873eedc24255ec2515bbf2a5bbcb364f89284f48ac18b177 SHA512 42c155654f118bff34b48d929b1732fd56126b8fd3e7657b5bd2f84275288ddf538572ed1152883c4aed5e9683de53b9b1f1c3613e5092e7bd1a5e165bed606d
DIST hpx_1.1.0.tar.gz 4374855 BLAKE2B 17caeb085e0167d51a1a89c73bce653938d9918776b9db07ae9171cb11570a440e2f88cea86d8b8066b7d102e9a24f1e8304b47b2ade161cbe4e27cce91e3b84 SHA512 09b69a5f14bdb4cbf629bc3a10a4e1dc4c0ab35efdb74386fc7f0135558db5f9557ae8de4edd0ade12cfb91a78e6cc2fac25efbdf9a21042abcb0f303eda1938
DIST hpx_1.2.0.tar.gz 3918088 BLAKE2B 7c5eccef6a58f683f94e59e3773e949945652e1fc7c883d134da5b6d32f21bb9a2f526d073260561657da518687ac96487f058715e51236a334b97b27a414451 SHA512 e2dec9484490f5a5fa7d60f712989f70068bcddac643d8b730d2d52aa2a7e49260b28c3becd519925a8e96e9a703473f19955adce087061cf50b861f4fed8ab1
+DIST hpx_1.2.1.tar.gz 3919474 BLAKE2B 5f62f97a047c1b931068b671855bc9d7b8ff03d7f26793ee58445fb4c567d68c6c24c87844c7a6463901d784e11afe475120a41038e783a67cc75ede508473c5 SHA512 057724de1ef252e941a776174fa594a855255b5600461725a4da6e9002b1424a1e59be3f8a40673bb3db5a8aabd3c7b38abbb78042490befe247dd73c921b87c
diff --git a/sys-cluster/hpx/hpx-1.2.1.ebuild b/sys-cluster/hpx/hpx-1.2.1.ebuild
new file mode 100644
index 000000000000..3fb751c6c5ad
--- /dev/null
+++ b/sys-cluster/hpx/hpx-1.2.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+if [ ${PV} == 9999 ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
+else
+ SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${PN}_${PV}"
+fi
+
+inherit cmake-utils fortran-2 multilib python-any-r1
+
+DESCRIPTION="C++ runtime system for parallel and distributed applications"
+HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+IUSE="doc examples jemalloc papi +perftools tbb test"
+
+RDEPEND="
+ tbb? ( dev-cpp/tbb )
+ >=dev-libs/boost-1.49
+ papi? ( dev-libs/papi )
+ perftools? ( >=dev-util/google-perftools-1.7.1 )
+ >=sys-apps/hwloc-1.8
+ >=sys-libs/libunwind-1
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+ doc? ( >=dev-libs/boost-1.56.0-r1:=[tools] )
+"
+REQUIRED_USE="
+ jemalloc? ( !perftools !tbb )
+ perftools? ( !jemalloc !tbb )
+ tbb? ( !jemalloc !perftools )
+ "
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+ local mycmakeargs=(
+ -DHPX_BUILD_EXAMPLES=OFF
+ -DHPX_MALLOC=system
+ -DLIB=$(get_libdir)
+ -Dcmake_dir=cmake
+ -DHPX_BUILD_DOCUMENTATION=$(usex doc)
+ -DHPX_JEMALLOC=$(usex jemalloc)
+ -DBUILD_TESTING=$(usex test)
+ -DHPX_GOOGLE_PERFTOOLS=$(usex perftools)
+ -DHPX_PAPI=$(usex papi)
+ )
+
+ use perftools && mycmakeargs+=( -DHPX_MALLOC=tcmalloc )
+ use jemalloc && mycmakeargs+=( -DHPX_MALLOC=jemalloc )
+ use tbb && mycmakeargs+=( -DHPX_MALLOC=tbbmalloc )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # avoid over-suscribing
+ cmake-utils_src_make -j1 tests
+}
+
+src_install() {
+ cmake-utils_src_install
+ mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin"
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}