summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-08-24 18:31:08 -0600
committerChristoph Junghans <junghans@gentoo.org>2017-08-24 18:31:24 -0600
commit6b4cd11346d68ce5c4c3af8ad876e266890621df (patch)
tree26951b20c01045dffc697204b26667f855298ae2 /sys-cluster/legion/legion-17.08.0.ebuild
parentapp-crypt/certbot-nginx: bup to 0.17.0 (diff)
downloadgentoo-6b4cd11346d68ce5c4c3af8ad876e266890621df.tar.gz
gentoo-6b4cd11346d68ce5c4c3af8ad876e266890621df.tar.bz2
gentoo-6b4cd11346d68ce5c4c3af8ad876e266890621df.zip
sys-cluster/legion: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-cluster/legion/legion-17.08.0.ebuild')
-rw-r--r--sys-cluster/legion/legion-17.08.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-cluster/legion/legion-17.08.0.ebuild b/sys-cluster/legion/legion-17.08.0.ebuild
new file mode 100644
index 000000000000..4d6ccbc9cb31
--- /dev/null
+++ b/sys-cluster/legion/legion-17.08.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+if [[ $PV = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="gasnet +hwloc test"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( sys-apps/hwloc )
+ "
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DLegion_ENABLE_TESTING=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+ cmake-utils_src_configure
+}