summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-07 05:52:07 +0100
committerSam James <sam@gentoo.org>2022-09-07 05:52:18 +0100
commit2c1e76900f3ab6b0a34f14372970325d6518340a (patch)
tree63aa0d4a9f057c070f9d56b650305dee0a623c37 /sys-cluster/sanlock
parentnet-misc/linuxptp: fix implicit function declaration for strncpy (diff)
downloadgentoo-2c1e76900f3ab6b0a34f14372970325d6518340a.tar.gz
gentoo-2c1e76900f3ab6b0a34f14372970325d6518340a.tar.bz2
gentoo-2c1e76900f3ab6b0a34f14372970325d6518340a.zip
sys-cluster/sanlock: fix implicit function declarations
Unlike normal missing includes, implicit function declaration fixes require a revbump as they can affect code generation. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/sanlock')
-rw-r--r--sys-cluster/sanlock/files/sanlock-3.8.4-implicit-func-decls.patch34
-rw-r--r--sys-cluster/sanlock/sanlock-3.8.4-r1.ebuild (renamed from sys-cluster/sanlock/sanlock-3.8.4.ebuild)2
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-cluster/sanlock/files/sanlock-3.8.4-implicit-func-decls.patch b/sys-cluster/sanlock/files/sanlock-3.8.4-implicit-func-decls.patch
new file mode 100644
index 000000000000..7e99d9b1f939
--- /dev/null
+++ b/sys-cluster/sanlock/files/sanlock-3.8.4-implicit-func-decls.patch
@@ -0,0 +1,34 @@
+https://pagure.io/sanlock/issue/8
+
+From 272f9838f3495f5e419f77e000762c420754c96d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sep 02 2022 22:58:56 +0000
+Subject: add missing system header string.h
+
+
+This is needed for mem* function prototypes used in these sources
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/src/sanlock_sock.c
++++ b/src/sanlock_sock.c
+@@ -12,6 +12,7 @@
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <stddef.h>
++#include <string.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+
+--- a/wdmd/wdmd_sock.c
++++ b/wdmd/wdmd_sock.c
+@@ -12,6 +12,7 @@
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <stddef.h>
++#include <string.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+
+
+
diff --git a/sys-cluster/sanlock/sanlock-3.8.4.ebuild b/sys-cluster/sanlock/sanlock-3.8.4-r1.ebuild
index 638cec0ffefb..d48b048e3ead 100644
--- a/sys-cluster/sanlock/sanlock-3.8.4.ebuild
+++ b/sys-cluster/sanlock/sanlock-3.8.4-r1.ebuild
@@ -25,9 +25,11 @@ DEPEND="
python? ( ${PYTHON_DEPS} )
"
RDEPEND="${DEPEND}"
+BDEPEND="sys-apps/which"
PATCHES=(
"${FILESDIR}/sanlock-fence_sanlock-LDFLAGS.patch"
+ "${FILESDIR}/sanlock-3.8.4-implicit-func-decls.patch"
)
CONFIG_CHECK="~SOFT_WATCHDOG"