summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2024-10-09 18:51:06 +0800
committerBenda Xu <heroxbd@gentoo.org>2024-10-18 21:37:07 +0800
commitf77f6be9737de0f9d1fa729a32eb3ed9c62ca66a (patch)
treecba0a001f817b5f02bee4a7abb2b1a9d5091d345 /sys-cluster/slurm
parentsys-cluster/slurm: add slurm-22.05.11 to collaborate with Debian. (diff)
downloadgentoo-f77f6be9737de0f9d1fa729a32eb3ed9c62ca66a.tar.gz
gentoo-f77f6be9737de0f9d1fa729a32eb3ed9c62ca66a.tar.bz2
gentoo-f77f6be9737de0f9d1fa729a32eb3ed9c62ca66a.zip
sys-cluster/slurm: use lazy binding to let plugins work.
Follow the guidence from slurm.spec and Debian turning off -bindnow. Bug: https://bugs.gentoo.org/698994 Reference: https://salsa.debian.org/hpc-team/slurm-wlm/-/blob/master/debian/rules Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sys-cluster/slurm')
-rw-r--r--sys-cluster/slurm/slurm-22.05.11.ebuild9
-rw-r--r--sys-cluster/slurm/slurm-24.05.3.ebuild9
2 files changed, 14 insertions, 4 deletions
diff --git a/sys-cluster/slurm/slurm-22.05.11.ebuild b/sys-cluster/slurm/slurm-22.05.11.ebuild
index 48a6b283d77a..3f4b55be81d8 100644
--- a/sys-cluster/slurm/slurm-22.05.11.ebuild
+++ b/sys-cluster/slurm/slurm-22.05.11.ebuild
@@ -21,14 +21,18 @@ else
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
fi
-inherit autotools bash-completion-r1 lua-single pam perl-module prefix toolchain-funcs systemd ${INHERIT_GIT} tmpfiles
+inherit autotools bash-completion-r1 flag-o-matic lua-single pam \
+ perl-module prefix toolchain-funcs systemd ${INHERIT_GIT} \
+ tmpfiles
DESCRIPTION="A Highly Scalable Resource Manager"
HOMEPAGE="https://www.schedmd.com https://github.com/SchedMD/slurm"
LICENSE="GPL-2"
SLOT="0"
-IUSE="X debug hdf5 html ipmi json lua multiple-slurmd +munge mysql numa nvml ofed pam perl slurmdbd slurmrestd static-libs torque ucx yaml"
+
+IUSE="X debug hdf5 html ipmi json lua multiple-slurmd +munge mysql numa
+ nvml ofed pam perl slurmdbd slurmrestd static-libs torque ucx yaml"
# See bug #813924 for hdf5lib < dep, needs proper fix
COMMON_DEPEND="
@@ -87,6 +91,7 @@ PATCHES=(
)
pkg_setup() {
+ append-ldflags -Wl,-z,lazy
use lua && lua-single_pkg_setup
}
diff --git a/sys-cluster/slurm/slurm-24.05.3.ebuild b/sys-cluster/slurm/slurm-24.05.3.ebuild
index 1f7beec432cf..2570ebff8b1b 100644
--- a/sys-cluster/slurm/slurm-24.05.3.ebuild
+++ b/sys-cluster/slurm/slurm-24.05.3.ebuild
@@ -21,14 +21,18 @@ else
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
fi
-inherit autotools bash-completion-r1 lua-single pam perl-module prefix toolchain-funcs systemd ${INHERIT_GIT} tmpfiles
+inherit autotools bash-completion-r1 flag-o-matic lua-single pam \
+ perl-module prefix toolchain-funcs systemd ${INHERIT_GIT} \
+ tmpfiles
DESCRIPTION="A Highly Scalable Resource Manager"
HOMEPAGE="https://www.schedmd.com https://github.com/SchedMD/slurm"
LICENSE="GPL-2"
SLOT="0"
-IUSE="X debug hdf5 html ipmi json lua multiple-slurmd +munge mysql numa nvml ofed pam perl slurmdbd slurmrestd static-libs torque ucx yaml"
+
+IUSE="X debug hdf5 html ipmi json lua multiple-slurmd +munge mysql numa
+ nvml ofed pam perl slurmdbd slurmrestd static-libs torque ucx yaml"
# See bug #813924 for hdf5lib < dep, needs proper fix
COMMON_DEPEND="
@@ -83,6 +87,7 @@ LIBSLURMDB_PERL_S="${S}/contribs/perlapi/libslurmdb/perl"
RESTRICT="test"
pkg_setup() {
+ append-ldflags -Wl,-z,lazy
use lua && lua-single_pkg_setup
}