summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-21 13:41:38 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-21 13:42:03 +0100
commit16d45fbb6685fc87caf145c997ed0a781edec633 (patch)
tree6e01dfc56feafd5b7867c0758ebfc26d866cf6fb /sys-devel/binutils-config
parentprofiles: Unmask games-board/scid. (diff)
downloadgentoo-16d45fbb6685fc87caf145c997ed0a781edec633.tar.gz
gentoo-16d45fbb6685fc87caf145c997ed0a781edec633.tar.bz2
gentoo-16d45fbb6685fc87caf145c997ed0a781edec633.zip
sys-devel/binutils-config: bump up to 5.3.2
Single new change: add --get-bin-path / --get-lib-path The options are symmetric to gcc-config's --get-bin-path / --get-lib-path. Useful to quickly get unprefixed tools into $PATH as: export PATH="$(gcc-config -B):$(binutils-config -B):$PATH" Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/binutils-config')
-rw-r--r--sys-devel/binutils-config/Manifest1
-rw-r--r--sys-devel/binutils-config/binutils-config-5.3.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-devel/binutils-config/Manifest b/sys-devel/binutils-config/Manifest
index 38ab097bed1f..2add03ff7040 100644
--- a/sys-devel/binutils-config/Manifest
+++ b/sys-devel/binutils-config/Manifest
@@ -1 +1,2 @@
DIST binutils-config-5.3.1.tar.xz 6688 BLAKE2B 3bc1b96a96b0c30e425f4ffd42f86a09e2a80cc3ad1dcf77d4b5d2d9eb3d6bc607f78dfff1ae888fe8abfe44405a1e4d1ab325aa92fc5889c18aa3187a506647 SHA512 c6d188b70935604a8a519c036dda210c20e5b6e916fab33e5026bd5c78adfff0a1aa85003759b751275576ff33471b25c920beb6b1c088115f28918389e09ce2
+DIST binutils-config-5.3.2.tar.xz 6840 BLAKE2B 4f02b8d1f3f8d4adca811772edba6167fc0e739f8ff1e895f30745eca45b559da6622bb76a0cac6016d6e864fe7ad6c921c64c7ec1c18c130b3a64a1dd7b9cbc SHA512 03dfecf46fee941b7b9fc35b63ffd22c795ab54f0444f16fc00ed44d27c81f6baaca33170fb700cfc4d767be469f305890882839536363bc466ad200d28d2228
diff --git a/sys-devel/binutils-config/binutils-config-5.3.2.ebuild b/sys-devel/binutils-config/binutils-config-5.3.2.ebuild
new file mode 100644
index 000000000000..5f9cd23da4a1
--- /dev/null
+++ b/sys-devel/binutils-config/binutils-config-5.3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit prefix
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/binutils-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Utility to change the binutils version being used"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Toolchain"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+native-symlinks"
+
+# We also RDEPEND on sys-apps/findutils which is in base @system
+RDEPEND="sys-apps/gentoo-functions"
+
+src_compile() {
+ emake DESTDIR="${D}" PV="${PV}" USE_NATIVE_LINKS="$(usex native-symlinks)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PV="${PV}" install
+
+ use prefix && eprefixify "${ED}"/usr/bin/${PN}
+}
+
+pkg_postinst() {
+ # Re-register all targets. USE flags or new versions can change
+ # installed symlinks.
+ local x
+ for x in $(binutils-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+ binutils-config ${x}
+ done
+}