summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-25 13:19:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-25 15:07:23 +0200
commitf9825bc30c803fc1ebda7b27a840ab4ef0bcd8bc (patch)
tree863097f5ccc1a6d9120185ef2bd23eb8bafd4e58 /sys-devel/clang-common/clang-common-14.0.6.ebuild
parentdev-ml/llvm-ocaml: Bump to 14.0.6 (diff)
downloadgentoo-f9825bc30c803fc1ebda7b27a840ab4ef0bcd8bc.tar.gz
gentoo-f9825bc30c803fc1ebda7b27a840ab4ef0bcd8bc.tar.bz2
gentoo-f9825bc30c803fc1ebda7b27a840ab4ef0bcd8bc.zip
sys-devel/clang-common: Bump to 14.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common/clang-common-14.0.6.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-14.0.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-14.0.6.ebuild b/sys-devel/clang-common/clang-common-14.0.6.ebuild
new file mode 100644
index 000000000000..798f9e9fb858
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-14.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+
+PDEPEND="
+ sys-devel/clang:*
+"
+
+LLVM_COMPONENTS=( clang/utils )
+llvm.org_set_globals
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}