summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 15:38:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-20 18:32:31 +0200
commit9ee2d5481409e61cb0fbdf935639107c48ce2859 (patch)
treea2f3e6d2b9a8f096c8d911aacb09c858ffc356dd /sys-devel/lld/lld-11.0.0.9999.ebuild
parentdev-ml/llvm-ocaml: Port to py3.9 (diff)
downloadgentoo-9ee2d5481409e61cb0fbdf935639107c48ce2859.tar.gz
gentoo-9ee2d5481409e61cb0fbdf935639107c48ce2859.tar.bz2
gentoo-9ee2d5481409e61cb0fbdf935639107c48ce2859.zip
sys-devel/lld: Apply patches in WORKDIR in 10.0.1+
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/lld/lld-11.0.0.9999.ebuild')
-rw-r--r--sys-devel/lld/lld-11.0.0.9999.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-devel/lld/lld-11.0.0.9999.ebuild b/sys-devel/lld/lld-11.0.0.9999.ebuild
index f15808abce81..03b235ef7eb6 100644
--- a/sys-devel/lld/lld-11.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-11.0.0.9999.ebuild
@@ -34,6 +34,13 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
+src_prepare() {
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
+ cmake-utils_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF