summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-01-16 14:50:00 +0100
committerMichał Górny <mgorny@gentoo.org>2019-01-16 15:52:26 +0100
commit13fe477702b5045043fb28064497bff378abb3b3 (patch)
tree646529f49525d84ae632f7df1b838c01c9a1c778 /sys-devel/llvm-common
parentsys-libs/compiler-rt-sanitizers: rpc issues were fixed upstream (diff)
downloadgentoo-13fe477702b5045043fb28064497bff378abb3b3.tar.gz
gentoo-13fe477702b5045043fb28064497bff378abb3b3.tar.bz2
gentoo-13fe477702b5045043fb28064497bff378abb3b3.zip
sys-devel/llvm-common: Add a live ebuild for 8.* branch
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common')
-rw-r--r--sys-devel/llvm-common/llvm-common-8.0.9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-8.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-8.0.9999.ebuild
new file mode 100644
index 000000000000..d83ddbc253e5
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-8.0.9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+EGIT_BRANCH="release_80"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/vim
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}