summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-10 08:36:26 +0100
committerSam James <sam@gentoo.org>2023-06-10 08:39:31 +0100
commiteea41edf93851097a97786068395a95d25b7e0c6 (patch)
treec1c6a5c691427c02be5daeec05cff62797bd9fe3 /sys-devel
parentsys-devel/gcc: sync 11.x with live (diff)
downloadgentoo-eea41edf93851097a97786068395a95d25b7e0c6.tar.gz
gentoo-eea41edf93851097a97786068395a95d25b7e0c6.tar.bz2
gentoo-eea41edf93851097a97786068395a95d25b7e0c6.zip
sys-devel/gcc: sync 12.x with live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-12.2.1_p20230428-r1.ebuild29
-rw-r--r--sys-devel/gcc/gcc-12.3.0.ebuild33
-rw-r--r--sys-devel/gcc/gcc-12.3.1_p20230526.ebuild33
-rw-r--r--sys-devel/gcc/gcc-12.3.1_p20230602.ebuild36
-rw-r--r--sys-devel/gcc/gcc-12.3.1_p20230609.ebuild36
5 files changed, 103 insertions, 64 deletions
diff --git a/sys-devel/gcc/gcc-12.2.1_p20230428-r1.ebuild b/sys-devel/gcc/gcc-12.2.1_p20230428-r1.ebuild
index bba4e8fe97f7..82b358a57be4 100644
--- a/sys-devel/gcc/gcc-12.2.1_p20230428-r1.ebuild
+++ b/sys-devel/gcc/gcc-12.2.1_p20230428-r1.ebuild
@@ -4,37 +4,39 @@
EAPI=8
TOOLCHAIN_PATCH_DEV="sam"
-PATCH_VER="2"
PATCH_GCC_VER="12.3.0"
+PATCH_VER="2"
MUSL_VER="1"
MUSL_GCC_VER="12.3.0"
-if [[ $(ver_cut 3) == 9999 ]] ; then
+if [[ ${PV} == *.9999 ]] ; then
MY_PV_2=$(ver_cut 2)
+ MY_PV_3=1
if [[ ${MY_PV_2} == 0 ]] ; then
MY_PV_2=0
+ MY_PV_3=0
else
- MY_PV_2=$(($(ver_cut 2) - 1))
+ MY_PV_2=$((${MY_PV_2} - 1))
fi
# e.g. 12.2.9999 -> 12.1.1
- TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.$(($(ver_cut 3) - 9998))
+ TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.${MY_PV_3}
elif [[ -n ${TOOLCHAIN_GCC_RC} ]] ; then
# Cheesy hack for RCs
MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
MY_P=${PN}-${MY_PV}
- GCC_TARBALL_SRC_URI="https://gcc.gnu.org/pub/gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
+ GCC_TARBALL_SRC_URI="mirror://gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
TOOLCHAIN_SET_S=no
S="${WORKDIR}"/${MY_P}
fi
inherit toolchain
-# Needs to be after inherit (for now?), bug #830908
-EGIT_BRANCH=releases/gcc-$(ver_cut 1)
-
-# Don't keyword live ebuilds
-if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
+if tc_is_live ; then
+ # Needs to be after inherit (for now?), bug #830908
+ EGIT_BRANCH=releases/gcc-$(ver_cut 1)
+elif [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
+ # Don't keyword live ebuilds
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ppc64 ~riscv ~s390 sparc x86"
fi
@@ -48,6 +50,13 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
toolchain_src_prepare
eapply_user
diff --git a/sys-devel/gcc/gcc-12.3.0.ebuild b/sys-devel/gcc/gcc-12.3.0.ebuild
index 963e5466b141..eb2841b23665 100644
--- a/sys-devel/gcc/gcc-12.3.0.ebuild
+++ b/sys-devel/gcc/gcc-12.3.0.ebuild
@@ -4,26 +4,26 @@
EAPI=8
TOOLCHAIN_PATCH_DEV="sam"
-PATCH_VER="2"
PATCH_GCC_VER="12.3.0"
+PATCH_VER="2"
MUSL_VER="1"
MUSL_GCC_VER="12.3.0"
-if [[ $(ver_cut 3) == 9999 ]] ; then
+if [[ ${PV} == *.9999 ]] ; then
MY_PV_2=$(ver_cut 2)
+ MY_PV_3=1
if [[ ${MY_PV_2} == 0 ]] ; then
MY_PV_2=0
+ MY_PV_3=0
else
- MY_PV_2=$(($(ver_cut 2) - 1))
+ MY_PV_2=$((${MY_PV_2} - 1))
fi
# e.g. 12.2.9999 -> 12.1.1
- TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.$(($(ver_cut 3) - 9998))
+ TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.${MY_PV_3}
elif [[ -n ${TOOLCHAIN_GCC_RC} ]] ; then
# Cheesy hack for RCs
- # Sometimes the RCs are e.g. 12.3 and not 12.3.0...
- #MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
- MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1)))-RC-$(ver_cut 5)
+ MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
MY_P=${PN}-${MY_PV}
GCC_TARBALL_SRC_URI="mirror://gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
TOOLCHAIN_SET_S=no
@@ -32,12 +32,12 @@ fi
inherit toolchain
-# Needs to be after inherit (for now?), bug #830908
-EGIT_BRANCH=releases/gcc-$(ver_cut 1)
-
-# Don't keyword live ebuilds
-if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+if tc_is_live ; then
+ # Needs to be after inherit (for now?), bug #830908
+ EGIT_BRANCH=releases/gcc-$(ver_cut 1)
+elif [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
+ # Don't keyword live ebuilds
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
if [[ ${CATEGORY} != cross-* ]] ; then
@@ -50,6 +50,13 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
toolchain_src_prepare
eapply_user
diff --git a/sys-devel/gcc/gcc-12.3.1_p20230526.ebuild b/sys-devel/gcc/gcc-12.3.1_p20230526.ebuild
index 963e5466b141..eb2841b23665 100644
--- a/sys-devel/gcc/gcc-12.3.1_p20230526.ebuild
+++ b/sys-devel/gcc/gcc-12.3.1_p20230526.ebuild
@@ -4,26 +4,26 @@
EAPI=8
TOOLCHAIN_PATCH_DEV="sam"
-PATCH_VER="2"
PATCH_GCC_VER="12.3.0"
+PATCH_VER="2"
MUSL_VER="1"
MUSL_GCC_VER="12.3.0"
-if [[ $(ver_cut 3) == 9999 ]] ; then
+if [[ ${PV} == *.9999 ]] ; then
MY_PV_2=$(ver_cut 2)
+ MY_PV_3=1
if [[ ${MY_PV_2} == 0 ]] ; then
MY_PV_2=0
+ MY_PV_3=0
else
- MY_PV_2=$(($(ver_cut 2) - 1))
+ MY_PV_2=$((${MY_PV_2} - 1))
fi
# e.g. 12.2.9999 -> 12.1.1
- TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.$(($(ver_cut 3) - 9998))
+ TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.${MY_PV_3}
elif [[ -n ${TOOLCHAIN_GCC_RC} ]] ; then
# Cheesy hack for RCs
- # Sometimes the RCs are e.g. 12.3 and not 12.3.0...
- #MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
- MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1)))-RC-$(ver_cut 5)
+ MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
MY_P=${PN}-${MY_PV}
GCC_TARBALL_SRC_URI="mirror://gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
TOOLCHAIN_SET_S=no
@@ -32,12 +32,12 @@ fi
inherit toolchain
-# Needs to be after inherit (for now?), bug #830908
-EGIT_BRANCH=releases/gcc-$(ver_cut 1)
-
-# Don't keyword live ebuilds
-if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+if tc_is_live ; then
+ # Needs to be after inherit (for now?), bug #830908
+ EGIT_BRANCH=releases/gcc-$(ver_cut 1)
+elif [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
+ # Don't keyword live ebuilds
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
if [[ ${CATEGORY} != cross-* ]] ; then
@@ -50,6 +50,13 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
toolchain_src_prepare
eapply_user
diff --git a/sys-devel/gcc/gcc-12.3.1_p20230602.ebuild b/sys-devel/gcc/gcc-12.3.1_p20230602.ebuild
index 4e2eee4f27cd..1ffe2b97a4bf 100644
--- a/sys-devel/gcc/gcc-12.3.1_p20230602.ebuild
+++ b/sys-devel/gcc/gcc-12.3.1_p20230602.ebuild
@@ -4,26 +4,26 @@
EAPI=8
TOOLCHAIN_PATCH_DEV="sam"
-PATCH_VER="2"
PATCH_GCC_VER="12.3.0"
+PATCH_VER="2"
MUSL_VER="1"
MUSL_GCC_VER="12.3.0"
-if [[ $(ver_cut 3) == 9999 ]] ; then
+if [[ ${PV} == *.9999 ]] ; then
MY_PV_2=$(ver_cut 2)
+ MY_PV_3=1
if [[ ${MY_PV_2} == 0 ]] ; then
MY_PV_2=0
+ MY_PV_3=0
else
- MY_PV_2=$(($(ver_cut 2) - 1))
+ MY_PV_2=$((${MY_PV_2} - 1))
fi
# e.g. 12.2.9999 -> 12.1.1
- TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.$(($(ver_cut 3) - 9998))
+ TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.${MY_PV_3}
elif [[ -n ${TOOLCHAIN_GCC_RC} ]] ; then
# Cheesy hack for RCs
- # Sometimes the RCs are e.g. 12.3 and not 12.3.0...
- #MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
- MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1)))-RC-$(ver_cut 5)
+ MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
MY_P=${PN}-${MY_PV}
GCC_TARBALL_SRC_URI="mirror://gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
TOOLCHAIN_SET_S=no
@@ -32,13 +32,14 @@ fi
inherit toolchain
-# Needs to be after inherit (for now?), bug #830908
-EGIT_BRANCH=releases/gcc-$(ver_cut 1)
-
-# Don't keyword live ebuilds
-#if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
-# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-#fi
+if tc_is_live ; then
+ # Needs to be after inherit (for now?), bug #830908
+ EGIT_BRANCH=releases/gcc-$(ver_cut 1)
+elif [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
+ # Don't keyword live ebuilds
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ :;
+fi
if [[ ${CATEGORY} != cross-* ]] ; then
# Technically only if USE=hardened *too* right now, but no point in complicating it further.
@@ -50,6 +51,13 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
toolchain_src_prepare
eapply_user
diff --git a/sys-devel/gcc/gcc-12.3.1_p20230609.ebuild b/sys-devel/gcc/gcc-12.3.1_p20230609.ebuild
index 4e2eee4f27cd..1ffe2b97a4bf 100644
--- a/sys-devel/gcc/gcc-12.3.1_p20230609.ebuild
+++ b/sys-devel/gcc/gcc-12.3.1_p20230609.ebuild
@@ -4,26 +4,26 @@
EAPI=8
TOOLCHAIN_PATCH_DEV="sam"
-PATCH_VER="2"
PATCH_GCC_VER="12.3.0"
+PATCH_VER="2"
MUSL_VER="1"
MUSL_GCC_VER="12.3.0"
-if [[ $(ver_cut 3) == 9999 ]] ; then
+if [[ ${PV} == *.9999 ]] ; then
MY_PV_2=$(ver_cut 2)
+ MY_PV_3=1
if [[ ${MY_PV_2} == 0 ]] ; then
MY_PV_2=0
+ MY_PV_3=0
else
- MY_PV_2=$(($(ver_cut 2) - 1))
+ MY_PV_2=$((${MY_PV_2} - 1))
fi
# e.g. 12.2.9999 -> 12.1.1
- TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.$(($(ver_cut 3) - 9998))
+ TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.${MY_PV_3}
elif [[ -n ${TOOLCHAIN_GCC_RC} ]] ; then
# Cheesy hack for RCs
- # Sometimes the RCs are e.g. 12.3 and not 12.3.0...
- #MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
- MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1)))-RC-$(ver_cut 5)
+ MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
MY_P=${PN}-${MY_PV}
GCC_TARBALL_SRC_URI="mirror://gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
TOOLCHAIN_SET_S=no
@@ -32,13 +32,14 @@ fi
inherit toolchain
-# Needs to be after inherit (for now?), bug #830908
-EGIT_BRANCH=releases/gcc-$(ver_cut 1)
-
-# Don't keyword live ebuilds
-#if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
-# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-#fi
+if tc_is_live ; then
+ # Needs to be after inherit (for now?), bug #830908
+ EGIT_BRANCH=releases/gcc-$(ver_cut 1)
+elif [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
+ # Don't keyword live ebuilds
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ :;
+fi
if [[ ${CATEGORY} != cross-* ]] ; then
# Technically only if USE=hardened *too* right now, but no point in complicating it further.
@@ -50,6 +51,13 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
toolchain_src_prepare
eapply_user