summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2025-01-19 13:55:30 +0100
committerSam James <sam@gentoo.org>2025-01-20 03:35:50 +0000
commit9022682446b0cc173822c8c2a4775d9f77d75948 (patch)
treec9feeeb56f306ac2da6d72692301b0509b3bf9dc /sys-fs/bees
parentsys-fs/bees: drop 0.10 (diff)
downloadgentoo-9022682446b0cc173822c8c2a4775d9f77d75948.tar.gz
gentoo-9022682446b0cc173822c8c2a4775d9f77d75948.tar.bz2
gentoo-9022682446b0cc173822c8c2a4775d9f77d75948.zip
sys-fs/bees: Update 9999 to latest master
Signed-off-by: Kai Krakow <kai@kaishome.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/bees')
-rw-r--r--sys-fs/bees/bees-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-fs/bees/bees-9999.ebuild b/sys-fs/bees/bees-9999.ebuild
index 88f0faef9827..965748b64f91 100644
--- a/sys-fs/bees/bees-9999.ebuild
+++ b/sys-fs/bees/bees-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,11 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Zygo/bees.git"
else
- SRC_URI="https://github.com/Zygo/bees/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ MY_PV=${PV/_/-}
+ MY_P=${P/_/-}
+ S=${WORKDIR}/${MY_P}
+
+ SRC_URI="https://github.com/Zygo/bees/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm64"
fi
@@ -28,10 +32,6 @@ RDEPEND="${DEPEND}"
CONFIG_CHECK="~BTRFS_FS"
ERROR_BTRFS_FS="CONFIG_BTRFS_FS: bees does currently only work with btrfs"
-PATCHES=(
- "${FILESDIR}/0001-context-demote-abandoned-toxic-match-to-debug-log-le.patch"
-)
-
pkg_pretend() {
if [[ ${MERGE_TYPE} != buildonly ]]; then
if kernel_is -lt 4 11; then
@@ -116,7 +116,7 @@ src_configure() {
DEFAULT_MAKE_TARGET=all
EOF
if [[ ${PV} != "9999" ]] ; then
- echo BEES_VERSION=v${PV} >>localconf || die
+ echo BEES_VERSION=v${MY_PV} >>localconf || die
fi
}