summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-06-28 22:27:02 +0800
committerWANG Xuerui <xen0n@gentoo.org>2023-06-29 01:31:47 +0800
commitb610dac270d8e0d73bf0b213202627f012b108ab (patch)
tree30dcd69fb03a5c79c9c833a1161a04b28a42cc3b /sys-fs/erofs-utils
parentdev-python/cx_Freeze: Bump to 6.15.2 (diff)
downloadgentoo-b610dac270d8e0d73bf0b213202627f012b108ab.tar.gz
gentoo-b610dac270d8e0d73bf0b213202627f012b108ab.tar.bz2
gentoo-b610dac270d8e0d73bf0b213202627f012b108ab.zip
sys-fs/erofs-utils: add 1.6
Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'sys-fs/erofs-utils')
-rw-r--r--sys-fs/erofs-utils/Manifest1
-rw-r--r--sys-fs/erofs-utils/erofs-utils-1.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-fs/erofs-utils/Manifest b/sys-fs/erofs-utils/Manifest
index 9b7bee76552b..150523cc2ad4 100644
--- a/sys-fs/erofs-utils/Manifest
+++ b/sys-fs/erofs-utils/Manifest
@@ -1 +1,2 @@
DIST erofs-utils-1.5.tar.gz 106559 BLAKE2B 69a2b93c0ba8c50fb3f75a53cc224490ab31f55e24055932091e85032a637c2be6d937ab42f068a2937e5b9d8b6054fd756e89b9333f47a6b6b35c20a421ed49 SHA512 0a9d593a9fef3c5976dc63e2927f47d070121ed07e6dda727b0a715b72cfe560c83bdf26ce41fe07b8cb5b66b0660105848e3f7c5a84f222296eb422d1cd5cba
+DIST erofs-utils-1.6.tar.gz 126558 BLAKE2B ad4ce3777c484d485b91f29a97c08499398595d654a4ad63e1cc6a75c176b0476d3af1d7a2bf1ef5f6df996281c1b1bdfdf004be4428c0c168652af68acd83d1 SHA512 1537c5cb60cb70c607b8c00408451f90122fe902d80c9d35dde7b9205588ae3513ddd7cb38d4062e55bb57e37d9b53a668752792e6cba0bc0d78176afed3e502
diff --git a/sys-fs/erofs-utils/erofs-utils-1.6.ebuild b/sys-fs/erofs-utils/erofs-utils-1.6.ebuild
new file mode 100644
index 000000000000..bae100e2e3a3
--- /dev/null
+++ b/sys-fs/erofs-utils/erofs-utils-1.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Userspace tools for EROFS"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git"
+LICENSE="GPL-2+"
+
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/${PN}.git/snapshot/${P}.tar.gz"
+KEYWORDS="~amd64 ~loong"
+
+SLOT="0"
+IUSE="fuse +lz4 +lzma selinux +uuid"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:0 )
+ lz4? ( app-arch/lz4:0= )
+ lzma? ( >=app-arch/xz-utils-5.4.0:0= )
+ selinux? ( sys-libs/libselinux:0= )
+ uuid? ( sys-apps/util-linux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable fuse)
+ $(use_enable lz4)
+ $(use_enable lzma)
+ $(use_with selinux)
+ $(use_with uuid)
+ )
+
+ econf "${myeconfargs[@]}"
+}