summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-01-08 03:33:00 -0600
committerTim Harder <radhermit@gentoo.org>2019-01-08 03:38:20 -0600
commit1460cd776ac6a779dbcde4ff08a624d2e575f238 (patch)
tree1c859362d2474af646ea3945bb3125cdd1a68e16 /sys-fs/squashfuse
parentsys-apps/pkgcore: update live ebuild deps (diff)
downloadgentoo-1460cd776ac6a779dbcde4ff08a624d2e575f238.tar.gz
gentoo-1460cd776ac6a779dbcde4ff08a624d2e575f238.tar.bz2
gentoo-1460cd776ac6a779dbcde4ff08a624d2e575f238.zip
sys-fs/squashfuse: version bump to 0.1.103
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-fs/squashfuse')
-rw-r--r--sys-fs/squashfuse/Manifest1
-rw-r--r--sys-fs/squashfuse/metadata.xml1
-rw-r--r--sys-fs/squashfuse/squashfuse-0.1.103.ebuild47
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-fs/squashfuse/Manifest b/sys-fs/squashfuse/Manifest
index e1cff1dc417f..eef45b65d0f0 100644
--- a/sys-fs/squashfuse/Manifest
+++ b/sys-fs/squashfuse/Manifest
@@ -1 +1,2 @@
DIST squashfuse-0.1.100.tar.gz 393548 BLAKE2B 642f0b00023f1914e6f4efd0e03c77d61c549eed0bff8f3128f415ece7c52d3f917e8856a1dccc3d1be06147ad0b80bdde79397c4f307bc316adb2224260b402 SHA512 e6a56354e71991ccbcbd2f9e6967f1f5a1056edbee286e6a6d6c35f777ed6e6494243633d070da700cf43a8bf7b56269087a0db1d4b2d45ed49f4830caad7927
+DIST squashfuse-0.1.103.tar.gz 399524 BLAKE2B 985ce64052c55a03d4889674682cf8b3bf6fab96de18d38b5b6125a6b2bdf0ec40e9f18a13bb77ea1a963fd0e7debf08d5f4819c543a62a818389b5fa7884815 SHA512 bc640898a5756ceed3260d9dea61dcb54588381b787a50c0fbfce35658fdf7d2788babf4882c369d1981ff853a91f043de8c68727aedc33646c26db4fb0ab2c0
diff --git a/sys-fs/squashfuse/metadata.xml b/sys-fs/squashfuse/metadata.xml
index 4b36f192fd0d..c8a507a9926c 100644
--- a/sys-fs/squashfuse/metadata.xml
+++ b/sys-fs/squashfuse/metadata.xml
@@ -13,5 +13,6 @@
</maintainer>
<use>
<flag name="lz4">Enable support for lz4 compression</flag>
+ <flag name="zstd">Enable support for zstd compression</flag>
</use>
</pkgmetadata>
diff --git a/sys-fs/squashfuse/squashfuse-0.1.103.ebuild b/sys-fs/squashfuse/squashfuse-0.1.103.ebuild
new file mode 100644
index 000000000000..f4654076461b
--- /dev/null
+++ b/sys-fs/squashfuse/squashfuse-0.1.103.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2016-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="FUSE filesystem to mount squashfs archives"
+HOMEPAGE="https://github.com/vasi/squashfuse"
+SRC_URI="https://github.com/vasi/squashfuse/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="lz4 lzma lzo static-libs +zlib zstd"
+REQUIRED_USE="|| ( lz4 lzma lzo zlib zstd )"
+
+COMMON_DEPEND="
+ >=sys-fs/fuse-2.8.6:0=
+ lzma? ( >=app-arch/xz-utils-5.0.4:= )
+ zlib? ( >=sys-libs/zlib-1.2.5-r2:= )
+ lzo? ( >=dev-libs/lzo-2.06:= )
+ lz4? ( >=app-arch/lz4-0_p106:= )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ filter-flags -flto* -fwhole-program -fno-common
+
+ local econfargs=(
+ $(use_enable static-libs static)
+ $(use lz4 || echo --without-lz4)
+ $(use lzma || echo --without-xz)
+ $(use lzo || echo --without-lzo)
+ $(use zlib || echo --without-zlib)
+ $(use zstd || echo --without-zstd)
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}