summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-10 21:41:18 +0100
committerSam James <sam@gentoo.org>2024-08-10 21:41:46 +0100
commit6e1623528f4f569c1cd40f24dd927c83c99c209e (patch)
treed8224a3b72b81085bd678a963d116d3cb4267355 /sys-fs/zfs
parentsys-fs/zfs-kmod: bump kernel version (diff)
downloadgentoo-6e1623528f4f569c1cd40f24dd927c83c99c209e.tar.gz
gentoo-6e1623528f4f569c1cd40f24dd927c83c99c209e.tar.bz2
gentoo-6e1623528f4f569c1cd40f24dd927c83c99c209e.zip
sys-fs/zfs: wire up new libunwind option
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/zfs')
-rw-r--r--sys-fs/zfs/zfs-2.2.5.ebuild4
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-fs/zfs/zfs-2.2.5.ebuild b/sys-fs/zfs/zfs-2.2.5.ebuild
index 71e2889ab794..5264247e69af 100644
--- a/sys-fs/zfs/zfs-2.2.5.ebuild
+++ b/sys-fs/zfs/zfs-2.2.5.ebuild
@@ -34,7 +34,7 @@ LICENSE="BSD-2 CDDL MIT"
# possible candidates: libuutil, libzpool, libnvpair. Those do not provide stable abi, but are considered.
# see libsoversion_check() below as well
SLOT="0/5"
-IUSE="custom-cflags debug dist-kernel kernel-builtin minimal nls pam python +rootfs selinux test-suite"
+IUSE="custom-cflags debug dist-kernel kernel-builtin minimal nls pam python +rootfs selinux test-suite unwind"
DEPEND="
dev-libs/openssl:=
@@ -47,6 +47,7 @@ DEPEND="
python? (
$(python_gen_cond_dep 'dev-python/cffi[${PYTHON_USEDEP}]' 'python*')
)
+ unwind? ( sys-libs/libunwind:= )
"
BDEPEND="
@@ -222,6 +223,7 @@ src_configure() {
$(use_enable nls)
$(use_enable pam)
$(use_enable python pyzfs)
+ $(use_with unwind libunwind)
--disable-static
$(usex minimal --without-python --with-python="${EPYTHON}")
)
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 7b38a676beca..d54b8ffe39b1 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -34,7 +34,7 @@ LICENSE="BSD-2 CDDL MIT"
# possible candidates: libuutil, libzpool, libnvpair. Those do not provide stable abi, but are considered.
# see libsoversion_check() below as well
SLOT="0/5"
-IUSE="custom-cflags debug dist-kernel kernel-builtin minimal nls pam python +rootfs selinux test-suite"
+IUSE="custom-cflags debug dist-kernel kernel-builtin minimal nls pam python +rootfs selinux test-suite unwind"
DEPEND="
dev-libs/openssl:=
@@ -47,6 +47,7 @@ DEPEND="
python? (
$(python_gen_cond_dep 'dev-python/cffi[${PYTHON_USEDEP}]' 'python*')
)
+ unwind? ( sys-libs/libunwind:= )
"
BDEPEND="
@@ -220,6 +221,7 @@ src_configure() {
$(use_enable nls)
$(use_enable pam)
$(use_enable python pyzfs)
+ $(use_with unwind libunwind)
--disable-static
$(usex minimal --without-python --with-python="${EPYTHON}")
)