summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-04-07 15:20:34 +0100
committerMarek Szuba <marecki@gentoo.org>2024-04-07 16:22:21 +0100
commit49185db260c2de92556f6dbe203991a80240bb38 (patch)
tree828d3c86d32d113771544d3631a1afda3c27a45f /sys-fs
parentsys-auth/yubico-piv-tool: add 2.5.1 (diff)
downloadgentoo-49185db260c2de92556f6dbe203991a80240bb38.tar.gz
gentoo-49185db260c2de92556f6dbe203991a80240bb38.tar.bz2
gentoo-49185db260c2de92556f6dbe203991a80240bb38.zip
sys-fs/ddrescue: add 1.28
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ddrescue/Manifest1
-rw-r--r--sys-fs/ddrescue/ddrescue-1.28.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-fs/ddrescue/Manifest b/sys-fs/ddrescue/Manifest
index 2baa6989a692..0bb770634960 100644
--- a/sys-fs/ddrescue/Manifest
+++ b/sys-fs/ddrescue/Manifest
@@ -1 +1,2 @@
DIST ddrescue-1.27.tar.lz 93496 BLAKE2B a8957819dec2255e446504c822331ae13a86193f4655cbe6d559a498db9daf8c0f8066355e395cfd44f08b2f15d831820003bdfde6fc59c8434a695f95bdbe21 SHA512 b9a8b462536c5ec29db69e3a5f70b0bce160d5c58373cb519f6d54aba2fc0c4907e74fbcd11d49291306dc29c76f1992575aef7cfff41f34748bbd96e33b745a
+DIST ddrescue-1.28.tar.lz 93823 BLAKE2B 8c212f0d495e0df8e0398b97730c812ea9ccb77bd42e730198222e9918e3652fc52d932449b1e0dc9bdd453a123e2450c962e33e98d9845ce81b9a934a5bbdaa SHA512 ad3df2361b3b0228e2875792e0f6b301dc4d9cefd3f4fcdbce180a53c32924ee026bd27397b8efc94f40ee10f5f9d453fa72bd19203b6cb90208881e287e2c46
diff --git a/sys-fs/ddrescue/ddrescue-1.28.ebuild b/sys-fs/ddrescue/ddrescue-1.28.ebuild
new file mode 100644
index 000000000000..0ba725b13aff
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.28.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic unpacker
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="https://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="static"
+
+BDEPEND="$(unpacker_src_uri_depends)"
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ einstalldocs
+}