summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaszlo Gombos <laszlo.gombos@gmail.com>2023-07-13 21:10:37 -0400
committerMike Gilbert <floppym@gentoo.org>2023-07-14 15:40:24 -0400
commitc9c2c64521bc82925ca230a8a538b1117e8fb4dc (patch)
treefbfc36951ea2071da4e78adcdc0bde23597c6466 /sys-kernel/dracut/dracut-057-r3.ebuild
parentdev-libs/libbytesize: Stabilize 2.8 sparc, #910344 (diff)
downloadgentoo-c9c2c64521bc82925ca230a8a538b1117e8fb4dc.tar.gz
gentoo-c9c2c64521bc82925ca230a8a538b1117e8fb4dc.tar.bz2
gentoo-c9c2c64521bc82925ca230a8a538b1117e8fb4dc.zip
sys-kernel/dracut: update optfeatures
Introduce optfeature for Squashfs, TPM 2.0 TSS, Bluetooth, network NVMe and BIOS-given device names. Add additional dependency required for the dmraid dracut module. Signed-off-by: Laszlo Gombos <laszlo.gombos@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31871 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-kernel/dracut/dracut-057-r3.ebuild')
-rw-r--r--sys-kernel/dracut/dracut-057-r3.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-kernel/dracut/dracut-057-r3.ebuild b/sys-kernel/dracut/dracut-057-r3.ebuild
index f226bb26ec13..84f1aaa2c235 100644
--- a/sys-kernel/dracut/dracut-057-r3.ebuild
+++ b/sys-kernel/dracut/dracut-057-r3.ebuild
@@ -157,10 +157,13 @@ pkg_postinst() {
optfeature \
"Allows use of dash instead of default bash (on your own risk)" \
app-shells/dash
+ optfeature \
+ "Allows use of busybox instead of default bash (on your own risk)" \
+ sys-apps/busybox
optfeature "Support iSCSI" sys-block/open-iscsi
optfeature "Support Logical Volume Manager" sys-fs/lvm2[lvm]
optfeature "Support MD devices, also known as software RAID devices" \
- sys-fs/mdadm
+ sys-fs/mdadm sys-fs/dmraid
optfeature "Support Device Mapper multipathing" sys-fs/multipath-tools
optfeature "Plymouth boot splash" '>=sys-boot/plymouth-0.8.5-r5'
optfeature "Support network block devices" sys-block/nbd
@@ -169,6 +172,11 @@ pkg_postinst() {
"Install ssh and scp along with config files and specified keys" \
virtual/openssh
optfeature "Enable logging with rsyslog" app-admin/rsyslog
+ optfeature "Support Squashfs" sys-fs/squashfs-tools
+ optfeature "Support TPM 2.0 TSS" app-crypt/tpm2-tools
+ optfeature "Support Bluetooth (experimental)" net-wireless/bluez
+ optfeature "Support BIOS-given device names" sys-apps/biosdevname
+ optfeature "Support network NVMe" sys-apps/nvme-cli
optfeature \
"Enable rngd service to help generating entropy early during boot" \
sys-apps/rng-tools