summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-27 04:14:21 +0100
committerSam James <sam@gentoo.org>2023-06-27 04:25:50 +0100
commit094dc1044179200943368bac692a9b8f03487dfc (patch)
tree959b28126b75a779cf28aac897d17a9519240d6f /sys-kernel/kpatch
parentapp-laptop/mbpfan: add 2.3.0, drop 2.2.1-r1 (diff)
downloadgentoo-094dc1044179200943368bac692a9b8f03487dfc.tar.gz
gentoo-094dc1044179200943368bac692a9b8f03487dfc.tar.bz2
gentoo-094dc1044179200943368bac692a9b8f03487dfc.zip
sys-kernel/kpatch: allow shellcheck as well as shellcheck-bin
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-kernel/kpatch')
-rw-r--r--sys-kernel/kpatch/kpatch-0.9.7.ebuild4
-rw-r--r--sys-kernel/kpatch/kpatch-0.9.8.ebuild2
-rw-r--r--sys-kernel/kpatch/kpatch-9999.ebuild4
3 files changed, 5 insertions, 5 deletions
diff --git a/sys-kernel/kpatch/kpatch-0.9.7.ebuild b/sys-kernel/kpatch/kpatch-0.9.7.ebuild
index c900d328d08d..d3729ed70f9a 100644
--- a/sys-kernel/kpatch/kpatch-0.9.7.ebuild
+++ b/sys-kernel/kpatch/kpatch-0.9.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,7 +31,7 @@ DEPEND="
${RDEPEND}
dev-libs/elfutils
sys-devel/bison
- test? ( dev-util/shellcheck-bin )
+ test? ( || ( dev-util/shellcheck-bin dev-util/shellcheck ) )
"
PATCHES=(
diff --git a/sys-kernel/kpatch/kpatch-0.9.8.ebuild b/sys-kernel/kpatch/kpatch-0.9.8.ebuild
index a4c2d6a25317..830df5138431 100644
--- a/sys-kernel/kpatch/kpatch-0.9.8.ebuild
+++ b/sys-kernel/kpatch/kpatch-0.9.8.ebuild
@@ -31,7 +31,7 @@ DEPEND="
${RDEPEND}
dev-libs/elfutils
sys-devel/bison
- test? ( dev-util/shellcheck-bin )
+ test? ( || ( dev-util/shellcheck-bin dev-util/shellcheck ) )
"
PATCHES=(
diff --git a/sys-kernel/kpatch/kpatch-9999.ebuild b/sys-kernel/kpatch/kpatch-9999.ebuild
index f75259ae7a68..bf640f01cef4 100644
--- a/sys-kernel/kpatch/kpatch-9999.ebuild
+++ b/sys-kernel/kpatch/kpatch-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,7 +31,7 @@ DEPEND="
${RDEPEND}
dev-libs/elfutils
sys-devel/bison
- test? ( dev-util/shellcheck-bin )
+ test? ( || ( dev-util/shellcheck-bin dev-util/shellcheck ) )
"
pkg_setup() {