summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2022-10-19 14:41:34 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2022-10-19 14:41:34 +0900
commit56e8dd8612432a16fc3e07329359d23404d9fb75 (patch)
tree212b18e5d5551ee430f650ca8df8c813a8e21892 /sys-kernel/kpatch
parentsys-kernel/kpatch: drop 0.9.4 (diff)
downloadgentoo-56e8dd8612432a16fc3e07329359d23404d9fb75.tar.gz
gentoo-56e8dd8612432a16fc3e07329359d23404d9fb75.tar.bz2
gentoo-56e8dd8612432a16fc3e07329359d23404d9fb75.zip
sys-kernel/kpatch: drop 0.9.6
Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-kernel/kpatch')
-rw-r--r--sys-kernel/kpatch/Manifest1
-rw-r--r--sys-kernel/kpatch/kpatch-0.9.6.ebuild100
2 files changed, 0 insertions, 101 deletions
diff --git a/sys-kernel/kpatch/Manifest b/sys-kernel/kpatch/Manifest
index 325519f1b607..2e6869005550 100644
--- a/sys-kernel/kpatch/Manifest
+++ b/sys-kernel/kpatch/Manifest
@@ -1,2 +1 @@
-DIST kpatch-0.9.6.tar.gz 260687 BLAKE2B 5c535af463f54d7be00fe987716dcb84ed17df69e4ccf5c0a6b4bde32704756c1c217ec43d9f338ce478ff6e0403e5c10f15055c56fbfa786b592b7d67427c6f SHA512 898c5704098c473187f2eab9bccd5fb3cfc31f4211492d658abcd0b7cac6d03f11a27df19a56ad17c20163803084ddf54a27defcf12b4975a8a8eb5dbad73f21
DIST kpatch-0.9.7.tar.gz 283662 BLAKE2B c57578b2e5db8582cb09b9ba2bf2040cc5a178cd6c8fdb7f14a0819c50fd71eb8576b08264d019678498e98baf2875c3bd38247ebae31a9631f0e6a17ec5941a SHA512 c876d9b1e5f6e6ab858fa6f302e78152beb3e50cedd93f3c61ab6f747e32199b0601ad4a36d426d43d0e9a37d9bf1d6bbfddccc86df4b31d5e3e6edead6cded3
diff --git a/sys-kernel/kpatch/kpatch-0.9.6.ebuild b/sys-kernel/kpatch/kpatch-0.9.6.ebuild
deleted file mode 100644
index e30e6e2e09cf..000000000000
--- a/sys-kernel/kpatch/kpatch-0.9.6.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic linux-mod
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dynup/${PN}.git"
-else
- SRC_URI="https://github.com/dynup/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Dynamic kernel patching for Linux"
-HOMEPAGE="https://github.com/dynup/kpatch"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="contrib +kpatch +kpatch-build kmod test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-crypt/pesign
- sys-libs/zlib
- sys-apps/pciutils
-"
-
-DEPEND="
- ${RDEPEND}
- dev-libs/elfutils
- sys-devel/bison
- test? ( dev-util/shellcheck-bin )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.9.4-no-werror.patch
-)
-
-pkg_setup() {
- if use kmod; then
- if kernel_is gt 3 9 0; then
- if ! linux_config_exists; then
- eerror "Unable to check the currently running kernel for kpatch support"
- eerror "Please be sure a .config file is available in the kernel src dir"
- eerror "and ensure the kernel has been built."
- else
- # Fail to build if these kernel options are not enabled (see kpatch/kmod/core/Makefile)
- CONFIG_CHECK="FUNCTION_TRACER HAVE_FENTRY MODULES SYSFS KALLSYMS_ALL"
- ERROR_FUNCTION_TRACER="CONFIG_FUNCTION_TRACER must be enabled in the kernel's config file"
- ERROR_HAVE_FENTRY="CONFIG_HAVE_FENTRY must be enabled in the kernel's config file"
- ERROR_MODULES="CONFIG_MODULES must be enabled in the kernel's config file"
- ERROR_SYSFS="CONFIG_SYSFS must be enabled in the kernel's config file"
- ERROR_KALLSYMS_ALL="CONFIG_KALLSYMS_ALL must be enabled in the kernel's config file"
- fi
- else
- eerror
- eerror "kpatch is not available for Linux kernels below 4.0.0"
- eerror
- die "Upgrade the kernel sources before installing kpatch."
- fi
- check_extra_config
- fi
-
-}
-
-src_prepare() {
- replace-flags '-O?' '-O1'
- default
-}
-
-src_compile() {
- use kpatch-build && emake -C kpatch-build
- use kpatch && emake -C kpatch
- use kmod && set_arch_to_kernel && emake -C kmod
- use contrib && emake -C contrib
- use test && emake check
-}
-
-src_install() {
- if use kpatch-build; then
- emake DESTDIR="${D}" PREFIX="/usr" install -C kpatch-build
- insinto /usr/share/${PN}/patch
- doins kmod/patch/kpatch{.lds.S,-macros.h,-patch.h,-patch-hook.c}
- doins kmod/patch/{livepatch-patch-hook.c,Makefile,patch-hook.c}
- doins kmod/core/kpatch.h
- doman man/kpatch-build.1
- fi
-
- if use kpatch; then
- emake DESTDIR="${D}" PREFIX="/usr" install -C kpatch
- doman man/kpatch.1
- fi
-
- use kmod && set_arch_to_kernel && emake DESTDIR="${D}" PREFIX="/usr" install -C kmod
- use contrib && emake DESTDIR="${D}" PREFIX="/usr" install -C contrib
-
- dodoc README.md doc/patch-author-guide.md
-}