summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrits Letteboer <dagraver@gmail.com>2024-01-17 10:30:49 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-01-27 11:39:27 +0200
commitbb2d31656c07befdd6f288e57b8d66869c8489bb (patch)
tree678ef4e353c10e9958907e2fa4c7b3e8b1354f96 /sys-kernel/pf-sources
parentgui-apps/wayvnc: add 0.7.2, drop 0.6.2 (diff)
downloadgentoo-bb2d31656c07befdd6f288e57b8d66869c8489bb.tar.gz
gentoo-bb2d31656c07befdd6f288e57b8d66869c8489bb.tar.bz2
gentoo-bb2d31656c07befdd6f288e57b8d66869c8489bb.zip
sys-kernel/pf-sources: add 6.7_p2
Signed-off-by: Frits Letteboer <dagraver@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-6.7_p2.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index ef990cc95761..7d756ec26013 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -15,3 +15,4 @@ DIST linux-6.6-pf4.tar.gz 229255097 BLAKE2B 01c2c4b84ad6bfa7b944acba6fcc5bd27edb
DIST linux-6.6-pf5.tar.gz 229408330 BLAKE2B a6e2f8bbab60461c7f3d70899aa9cd0fb90bdb51eee2a969fc85a47e1316f9c70fce108f88d4aa9197524ca2cb97ef9e617aa030b2bcc4fd93c7b9be90a771b0 SHA512 3c49c82a66b0bf86dd9a65c6695682d4bc3f48c8b375fc05846c2efee19a6d99b548142e1e121064912fd36829235716f81a5552ae01a414ee6ebf1ca9605434
DIST linux-6.6-pf6.tar.gz 229421927 BLAKE2B c2ebb40db76c282e3d3db0f06d5effec815f543b196ec7d048197508b72294fb1acfd4c0a09db3da433cbcd749bd71e765222a2102fdc87e920bb2f4e80bf4d2 SHA512 c94bc93e88127fc2e4b13604cead8eaa2cb191e35633857ac7b57022604cb9ef9791cbb4db78b79a174eb4fb4c36ecb71173c3fc897540ccf93f991abaf02cee
DIST linux-6.7-pf1.tar.gz 232766936 BLAKE2B 31ba8ebdabeb8dc1e54c995b7f90138f3c45f4931f5aa24f1fe211854e47ec823ad3ae4f23f2f4474a41c823d977a707d14d79e200a1f9607bd36efb8524e00e SHA512 91ae92179216a93d24b9db009fbeeeb7b85ea7547921060acb0c4aa5f1c9a2282dea035dd97e66439ee87ed89ff6b531b94a5529e68cff56eee89158a4558982
+DIST linux-6.7-pf2.tar.gz 232630345 BLAKE2B 9193b6e8a910c54a39dbe2c6a379e09305a85eec5328a8a8ec25374654f5a39f7ca64795a688eb4d89dafc8e2664514fc1153b540eca6cf89895330fc4f92a48 SHA512 3dba41edc9bd8b3848604fe1d82520e983cbc7706d77f17c7863ccf5c2cf9647987ef6682f6a3bd250fd53e708f2092ce9b354d20c90809ffc66245d225f79c3
diff --git a/sys-kernel/pf-sources/pf-sources-6.7_p2.ebuild b/sys-kernel/pf-sources/pf-sources-6.7_p2.ebuild
new file mode 100644
index 000000000000..4b3ad9c0fee3
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-6.7_p2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Define what default functions to run.
+ETYPE="sources"
+
+# Use genpatches but don't include the 'experimental' use flag.
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Genpatches version to use. -pf patch set already includes vanilla linux updates. Regularly "1"
+# is the wanted value here, but the genpatches patch set can be bumped if it includes some
+# important fixes. src_prepare() will handle deleting the updated vanilla linux patches.
+# See https://archives.gentoo.org/gentoo-kernel/ (or subscribe to the list) to see all patches.
+K_GENPATCHES_VER="1"
+
+# -pf patch set already sets EXTRAVERSION to kernel Makefile.
+K_NOSETEXTRAVERSION="1"
+
+# pf-sources is not officially supported/covered by the Gentoo security team.
+K_SECURITY_UNSUPPORTED="1"
+
+# Define which parts to use from genpatches - experimental is already included in the -pf patch
+# set.
+K_WANT_GENPATCHES="base extras"
+
+# Major kernel version, e.g. 5.14.
+SHPV="${PV/_p*/}"
+
+# Replace "_p" with "-pf", since using "-pf" is not allowed for an ebuild name by PMS.
+PFPV="${PV/_p/-pf}"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://pfkernel.natalenko.name/
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="https://codeberg.org/pf-kernel/linux/archive/v${PFPV}.tar.gz -> linux-${PFPV}.tar.gz
+ ${GENPATCHES_URI}"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PFPV}"
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_unpack() {
+ # Since the Codeberg-hosted pf-sources include full kernel sources, we need to manually override
+ # the src_unpack phase because kernel-2_src_unpack() does a lot of unwanted magic here.
+ unpack ${A}
+
+ mv linux linux-${PFPV} || die "Failed to move source directory"
+}
+
+src_prepare() {
+ # When genpatches basic version is bumped, it also includes vanilla linux updates. Those are
+ # already in the -pf patch set, so need to remove the vanilla linux patches to avoid conflicts.
+ if [[ ${K_GENPATCHES_VER} -ne 1 ]]; then
+ find "${WORKDIR}"/ -type f -name '10*linux*patch' -delete ||
+ die "Failed to delete vanilla linux patches in src_prepare."
+ fi
+
+ # kernel-2_src_prepare doesn't apply PATCHES(). Chosen genpatches are also applied here.
+ eapply "${WORKDIR}"/*.patch
+ default
+}
+
+pkg_postinst() {
+ # Fixes "wrongly" detected directory name, bgo#862534.
+ local KV_FULL="${PFPV}"
+ kernel-2_pkg_postinst
+
+ optfeature "userspace KSM helper" sys-process/uksmd
+}
+
+pkg_postrm() {
+ # Same here, bgo#862534.
+ local KV_FULL="${PFPV}"
+ kernel-2_pkg_postrm
+}