summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-09-23 13:42:25 -0400
committerMike Pagano <mpagano@gentoo.org>2024-09-23 13:42:25 -0400
commit1f0dab0fc8d6194e7b5cd065ea15c7490fc60577 (patch)
tree30cd3d3e65dc827c68ef719b08f1a3fc7baaf0a6 /sys-kernel
parentdev-lang/python: Stabilize 3.8.20_p2 sparc, #939862 (diff)
downloadgentoo-1f0dab0fc8d6194e7b5cd065ea15c7490fc60577.tar.gz
gentoo-1f0dab0fc8d6194e7b5cd065ea15c7490fc60577.tar.bz2
gentoo-1f0dab0fc8d6194e7b5cd065ea15c7490fc60577.zip
sys-kernel/linux-docs: add 6.10.11
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-docs/Manifest1
-rw-r--r--sys-kernel/linux-docs/linux-docs-6.10.11.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/Manifest b/sys-kernel/linux-docs/Manifest
index 1eb0a26c4dd6..73163fb40a07 100644
--- a/sys-kernel/linux-docs/Manifest
+++ b/sys-kernel/linux-docs/Manifest
@@ -1 +1,2 @@
+DIST linux-6.10.11.tar.xz 145185812 BLAKE2B 55380d2af9fc535f6359cdb9b36612d1f81f2f140652f44bf927c320dda382109c9fb9591cc741914d3221e8d8bda954a10dbbeff8c163bf1ed57eff1831c8df SHA512 bb118bf74c0fd613e55e84f849849124f1d6093cb57c178258e2210e400e9fe492c16578bba583b1434b65175ebe1f20dfb722c271bf71b1157d38f3c0b2bca3
DIST linux-6.9.2.tar.xz 144109112 BLAKE2B ae19877e19239c2b521cdf04d182c0ee849228c9ecb4c9dddb626d85ed51faaa5215cc70b5c1ad203c346df85197cd5512894a27eba1c1fd6add9cd2fbaa2a3e SHA512 a168f5b3e7ee7451d5bb1c7f6c090d6002330a4529ef74b2e47f6902ba3d6feaa8dc89f7b5a072d52f6933fd08354a0ff1e12f22240ce53c758c144d4ad132cd
diff --git a/sys-kernel/linux-docs/linux-docs-6.10.11.ebuild b/sys-kernel/linux-docs/linux-docs-6.10.11.ebuild
new file mode 100644
index 000000000000..649be8df5e95
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-6.10.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10,11,12} )
+inherit linux-info python-any-r1 toolchain-funcs
+
+MY_P=linux-${PV}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/v6.x/${MY_P}.tar.xz"
+
+S=${WORKDIR}/${MY_P}
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="graphviz"
+
+RDEPEND="graphviz? ( >=media-gfx/graphviz-5.0.0 )"
+
+BDEPEND="${PYTHON_DEPS}
+ >=dev-python/sphinx-7.2.3
+ dev-python/sphinx-rtd-theme
+ media-libs/fontconfig
+ $(python_gen_any_dep '
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+ ')"
+
+src_prepare() {
+ default
+ # Fix the Python shebangs.
+ python_fix_shebang "${S}/Documentation/sphinx/"
+}
+
+src_compile() {
+ local ARCH="$(tc-arch-kernel)"
+ unset KBUILD_OUTPUT
+ HTML_DOCS=( Documentation/output/. )
+ emake htmldocs
+}
+
+src_install() {
+ einstalldocs
+}