summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-02-07 17:43:24 -0500
committerMike Pagano <mpagano@gentoo.org>2021-02-07 17:43:24 -0500
commitb26e5f3b085a101a0aeb7f89537b9c0f946be40b (patch)
tree64b380766f808d25bcf6028c18c19880e2355dc5 /sys-kernel
parentwww-client/chromium: beta channel bump to 89.0.4389.40 (diff)
downloadgentoo-b26e5f3b085a101a0aeb7f89537b9c0f946be40b.tar.gz
gentoo-b26e5f3b085a101a0aeb7f89537b9c0f946be40b.tar.bz2
gentoo-b26e5f3b085a101a0aeb7f89537b9c0f946be40b.zip
sys-kernel/git-sources: Linux patch 5.11-rc7
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.11_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 9450337a1fd4..93b383d92c3f 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-5.11-rc3.patch 75045235 BLAKE2B d159e9e4bedcf6838e0b81462b53445955e59
DIST patch-5.11-rc4.patch 75392493 BLAKE2B efc6b837641883d1ed7e165d5ba08a36ec85c3bfce49f4f8a0ed09d39df6ecf5844908c13a0bd2792c3dd2a57073dae211934f681482d3a04c0a3589a0776f68 SHA512 072cca3d9bc343b791278258102186646fb46f4808680c71cbe55ba3574448711aaa85b34e8f664a354d69d1665759c196ed37e23f1c0285851b0d2538ff173d
DIST patch-5.11-rc5.patch 75678864 BLAKE2B 8f8afe6935e2d9616981a87c753cc517772f9b0e29d027518fda903f2bd068b0c376ccd668bab489b155875589962211a430880d44945d1faa6d53bd06b5deb2 SHA512 7665e1bd8c58567af774a85065c28a8ded29520eaca4b6ff367ab99a6ce26091e1097949baf23455b5d20e04b9214410dea3d3812b81e91701f6eb40a6d52df8
DIST patch-5.11-rc6.patch 75970283 BLAKE2B b19ab87b876e41d1efb64d7d542e5493765843fae37a8a9fd1a0e8e4f74a59925a576ad0319dd5ca9133d4a5c6a6080a0e65100dd253b6236dd9b50dbcf2c7e1 SHA512 7096fd281ce60fff3b03244d87fbef06c3b684e95162d19093abcaeb6eb6e0a10e47035f093be90d5760d5dedfcd7a95ccb4009118a7fbc2518ced6aee1a1158
+DIST patch-5.11-rc7.patch 76220368 BLAKE2B 73e6c1e8746f980e2f26d32b2edca4c068277360f6bf31e5bd35633415b8a0ab9e23077eddac50bb9a2fb5943c4dfa4df9fcde429baf107bed6eabb0c71bea7f SHA512 ace16d352757da8344c7f3b55900e8a59a8ccd2f26c943dc09f54107e6617dd5ad7427bb0c674fc468b1357298ead34224013e4e0b70d4a23b6fa9f605b900aa
diff --git a/sys-kernel/git-sources/git-sources-5.11_rc7.ebuild b/sys-kernel/git-sources/git-sources-5.11_rc7.ebuild
new file mode 100644
index 000000000000..d3797acbcee8
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.11_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.10"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}