summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-17 17:22:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-17 21:30:07 +0200
commitb717cd74c1ecc7b735b5eb2c323c57a4a74dc282 (patch)
treed7f325da6b34623e501d0ac264dee9d9f6278277 /sys-kernel
parentsys-kernel/vanilla-kernel: Bump to 5.10.180 (diff)
downloadgentoo-b717cd74c1ecc7b735b5eb2c323c57a4a74dc282.tar.gz
gentoo-b717cd74c1ecc7b735b5eb2c323c57a4a74dc282.tar.bz2
gentoo-b717cd74c1ecc7b735b5eb2c323c57a4a74dc282.zip
sys-kernel/gentoo-kernel: Bump to 5.10.180
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gentoo-kernel/Manifest2
-rw-r--r--sys-kernel/gentoo-kernel/gentoo-kernel-5.10.180.ebuild134
2 files changed, 136 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-kernel/Manifest b/sys-kernel/gentoo-kernel/Manifest
index db3f5d100161..0f80c46d06c5 100644
--- a/sys-kernel/gentoo-kernel/Manifest
+++ b/sys-kernel/gentoo-kernel/Manifest
@@ -1,5 +1,7 @@
DIST genpatches-5.10-189.base.tar.xz 5251680 BLAKE2B ef349b00e1ca8cedc2b580a07e66e8906436198ec7019a8881b2b647152861554fc1b0099f4fcef39497b3a3edd3657c87974ec7b88a01e580ce421a23e2a706 SHA512 94d65f1cdba7415021ac031b2ab896d7b2b15692f5e826833abf8c285a3eda6a8e8e88a57a8f11ccbc5ae94437b732ac6fa974bd26bafa3b426e3d61bc8656c2
DIST genpatches-5.10-189.extras.tar.xz 3872 BLAKE2B 78ab95ce3f57e4ba86655cd54009252807e32fd0b03228180fb26a47ae9e595e468e549c21a5141dc8214e55fcfa46e63e5f4e866e4113b8d3beebb99512cb86 SHA512 cc6d60a70a1f575ce69a14c265a36e58126a011cafc5a2bc7c569e0d1b626855f1cf430c44775d2602ad35144b449a8f1db1da8594f513edae4329ba354e0347
+DIST genpatches-5.10-190.base.tar.xz 5340156 BLAKE2B bff4b95cacad5f8c099b559091b9c103e6989940898910861b7f8c95e7a110a055ef09d1f3db6158ca58f7faae4880a04a626002be9edb856e4260fd7d1c165b SHA512 729e3c2b3d5d1a2e4c793d4c6424965a28b65b69d2c8b9675fb7f531ccb4018419ef77e46a089640f02521f4b230eaabcdef69adc161e0aae21ac9716f130b61
+DIST genpatches-5.10-190.extras.tar.xz 3868 BLAKE2B 216298c7f06796d708bc78bca0606f918dde6254915c6f3732c36d6025054793dcdcb9bf986cd16b8a7cf505b0e2308256c898c5f3dc6eaf66819253e58eb445 SHA512 72fe6586ed405f2fa0737875bbac6d823f28c0260ad681135cdcd491376936d6494b92f7710a373bbb5ca2c4a4d744cc96bbb2a96872faeed9136cdd8c928e9b
DIST genpatches-5.15-116.base.tar.xz 4433124 BLAKE2B 1ace5f7ac7fe7dee5ca92c8228fa07f1abe85d92040adc0d2b83c2d5f55976c4ecfc0a3ed4575d5528db1eab14b65250d25d9fb28a880422385a45a887117820 SHA512 7346fe13050c49737f98e5ad7bdb848caf693b2e3129a7e9e382f1c6462242dcdae1fc7e184b10f7593159c7d6c3cd8bf69dd1d66abb604746871123424563f1
DIST genpatches-5.15-116.extras.tar.xz 3928 BLAKE2B 0130495424324f43fcb5f29b4178c56b43b01c4a7ca7a3b95ac07130f44d6875519d0ee79d9cf8a9912bd6c6d8bb81a0adcd17f27da1e59e24f19073d9a20cff SHA512 ece809c981c8d2c5ed7ec66df69dec3920cc75e7e43145c0ca5dbc577e16cc58880d449d8503d1863974fd2fb707a403b5a9b5ad02d9835e01c45637fd6bcfd7
DIST genpatches-5.15-117.base.tar.xz 4520724 BLAKE2B a495289b18d587d3a02d792644d09b63e0898c65dd88c23cb96983097bcc18ff6a06ea34427c7ea414ee8e93ccdb84d9963265b9bfd52eabd44d50a3b56ecb4f SHA512 218ef84108ce10983a85f3616ea3876dc616434e97add82e201758325c7f6bc3dce14273f86f5f1729c33a8fcae2111b241969ccdc53afcff775d7d683f2588a
diff --git a/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.180.ebuild b/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.180.ebuild
new file mode 100644
index 000000000000..91e1b5a2d288
--- /dev/null
+++ b/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.180.ebuild
@@ -0,0 +1,134 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit kernel-build toolchain-funcs
+
+MY_P=linux-${PV%.*}
+GENPATCHES_P=genpatches-${PV%.*}-$(( ${PV##*.} + 10 ))
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+CONFIG_VER=5.10.12
+CONFIG_HASH=836165dd2dff34e4f2c47ca8f9c803002c1e6530
+GENTOO_CONFIG_VER=g7
+
+DESCRIPTION="Linux kernel built with Gentoo patches"
+HOMEPAGE="
+ https://wiki.gentoo.org/wiki/Project:Distribution_Kernel
+ https://www.kernel.org/
+"
+SRC_URI+="
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://dev.gentoo.org/~mpagano/dist/genpatches/${GENPATCHES_P}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/dist/genpatches/${GENPATCHES_P}.extras.tar.xz
+ https://github.com/projg2/gentoo-kernel-config/archive/${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ amd64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64-fedora.config
+ -> kernel-x86_64-fedora.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64-fedora.config
+ -> kernel-aarch64-fedora.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-ppc64le-fedora.config
+ -> kernel-ppc64le-fedora.config.${CONFIG_VER}
+ )
+ x86? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686-fedora.config
+ -> kernel-i686-fedora.config.${CONFIG_VER}
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug hardened"
+REQUIRED_USE="arm? ( savedconfig )"
+
+RDEPEND="
+ !sys-kernel/gentoo-kernel-bin:${SLOT}
+"
+BDEPEND="
+ debug? ( dev-util/pahole )
+"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}
+"
+
+QA_FLAGS_IGNORED="
+ usr/src/linux-.*/scripts/gcc-plugins/.*.so
+ usr/src/linux-.*/vmlinux
+"
+
+src_prepare() {
+ local PATCHES=(
+ # meh, genpatches have no directory
+ "${WORKDIR}"/*.patch
+ )
+ default
+
+ local biendian=false
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ arm)
+ return
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ hppa)
+ return
+ ;;
+ ppc)
+ # assume powermac/powerbook defconfig
+ # we still package.use.force savedconfig
+ cp "${WORKDIR}/${MY_P}/arch/powerpc/configs/pmac32_defconfig" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local myversion="-gentoo-dist"
+ use hardened && myversion+="-hardened"
+ echo "CONFIG_LOCALVERSION=\"${myversion}\"" > "${T}"/version.config || die
+ local dist_conf_path="${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"
+
+ local merge_configs=(
+ "${T}"/version.config
+ "${dist_conf_path}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${dist_conf_path}"/no-debug.config
+ )
+ if use hardened; then
+ merge_configs+=( "${dist_conf_path}"/hardened-base.config )
+
+ tc-is-gcc && merge_configs+=( "${dist_conf_path}"/hardened-gcc-plugins.config )
+
+ if [[ -f "${dist_conf_path}/hardened-${ARCH}.config" ]]; then
+ merge_configs+=( "${dist_conf_path}/hardened-${ARCH}.config" )
+ fi
+ fi
+
+ # this covers ppc64 and aarch64_be only for now
+ if [[ ${biendian} == true && $(tc-endian) == big ]]; then
+ merge_configs+=( "${dist_conf_path}/big-endian.config" )
+ fi
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}