summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 10:35:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 14:27:00 +0200
commit5c9d3b30a294c77b6d7fcf872bb3bffb330c680f (patch)
treec34da6b9b00248b249137f1201a29dd16733ddc3 /sys-libs/compiler-rt-sanitizers
parentsys-libs/compiler-rt: Modernize (diff)
downloadgentoo-5c9d3b30a294c77b6d7fcf872bb3bffb330c680f.tar.gz
gentoo-5c9d3b30a294c77b6d7fcf872bb3bffb330c680f.tar.bz2
gentoo-5c9d3b30a294c77b6d7fcf872bb3bffb330c680f.zip
sys-libs/compiler-rt-sanitizers: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/compiler-rt-sanitizers')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-15.0.0.9999.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-15.0.0.9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-15.0.0.9999.ebuild
index 12e5eb2d01e7..3249418afcfa 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-15.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-15.0.0.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit check-reqs cmake flag-o-matic llvm llvm.org python-any-r1
@@ -27,14 +27,19 @@ REQUIRED_USE="
test? (
cfi? ( ubsan )
gwp-asan? ( scudo )
- )"
-RESTRICT="!test? ( test ) !clang? ( test )"
+ )
+"
+RESTRICT="
+ !clang? ( test )
+ !test? ( test )
+"
CLANG_SLOT=${SLOT%%.*}
# llvm-6 for new lit options
DEPEND="
>=sys-devel/llvm-6
- virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]"
+ virtual/libcrypt[abi_x86_32(-)?,abi_x86_64(-)?]
+"
BDEPEND="
>=dev-util/cmake-3.16
clang? ( sys-devel/clang )
@@ -47,7 +52,8 @@ BDEPEND="
)
!test? (
${PYTHON_DEPS}
- )"
+ )
+"
LLVM_COMPONENTS=( compiler-rt cmake )
LLVM_TEST_COMPONENTS=( llvm/lib/Testing/Support llvm/utils/unittest )