summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 23:08:40 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-23 20:30:51 +0200
commitcc57fc296b8db42887f2a99293e66668ea230876 (patch)
tree3c44f74c2a6131bf5c5b1eba4c6366684ebaa0af /sys-libs/llvm-libunwind
parentsys-libs/compiler-rt-sanitizers: Dedupe with new eclass code (diff)
downloadgentoo-cc57fc296b8db42887f2a99293e66668ea230876.tar.gz
gentoo-cc57fc296b8db42887f2a99293e66668ea230876.tar.bz2
gentoo-cc57fc296b8db42887f2a99293e66668ea230876.zip
sys-libs/llvm-libunwind: Dedupe with new eclass code
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-10.0.1.9999.ebuild16
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-10.0.1_rc1.ebuild16
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild16
3 files changed, 6 insertions, 42 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-10.0.1.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-10.0.1.9999.ebuild
index 6d15a7f4a17c..711bac7d068f 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-10.0.1.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-10.0.1.9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1
+inherit cmake-multilib llvm llvm.org python-any-r1
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://github.com/llvm-mirror/libunwind"
@@ -27,9 +27,6 @@ BDEPEND="
test? ( >=sys-devel/clang-3.9.0
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -38,13 +35,6 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
-src_prepare() {
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
-}
-
multilib_src_configure() {
local libdir=$(get_libdir)
@@ -60,13 +50,11 @@ multilib_src_configure() {
)
if use test; then
local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
-
[[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
)
fi
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-10.0.1_rc1.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-10.0.1_rc1.ebuild
index 6d15a7f4a17c..711bac7d068f 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-10.0.1_rc1.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-10.0.1_rc1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1
+inherit cmake-multilib llvm llvm.org python-any-r1
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://github.com/llvm-mirror/libunwind"
@@ -27,9 +27,6 @@ BDEPEND="
test? ( >=sys-devel/clang-3.9.0
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -38,13 +35,6 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
-src_prepare() {
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
-}
-
multilib_src_configure() {
local libdir=$(get_libdir)
@@ -60,13 +50,11 @@ multilib_src_configure() {
)
if use test; then
local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
-
[[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
)
fi
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild
index 6d15a7f4a17c..711bac7d068f 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1
+inherit cmake-multilib llvm llvm.org python-any-r1
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://github.com/llvm-mirror/libunwind"
@@ -27,9 +27,6 @@ BDEPEND="
test? ( >=sys-devel/clang-3.9.0
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -38,13 +35,6 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
-src_prepare() {
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
-}
-
multilib_src_configure() {
local libdir=$(get_libdir)
@@ -60,13 +50,11 @@ multilib_src_configure() {
)
if use test; then
local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
-
[[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
)
fi